Bug 804933 - RTC wake up does not work with windows guests
Summary: RTC wake up does not work with windows guests
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: seabios
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Gleb Natapov
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-20 08:52 UTC by Gleb Natapov
Modified: 2013-12-09 00:56 UTC (History)
11 users (show)

Fixed In Version: seabios-0.6.1.2-17.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Clone Of:
Environment:
Last Closed: 2012-06-20 12:55:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0802 normal SHIPPED_LIVE seabios bug fix and enhancement update 2012-06-19 19:51:36 UTC

Description Gleb Natapov 2012-03-20 08:52:41 UTC

Comment 5 Sibiao Luo 2012-03-30 03:09:54 UTC
Hi all,

   I have tested it on qemu-kvm-0.12.1.2-2.253.el6.x86_64 with the seabios-0.6.1.2-15.el6.x86_64, but the result of my test still hit this issue, the RTC wake up does not work for windows 7 guest. I have no idea about how to configure windows to wakeup with RTC, maybe miss some steps, please help to check my steps.

Version-Release number of selected component (if applicable):
host info:
# uname -r && rpm -q qemu-kvm
2.6.32-251.el6.x86_64
qemu-kvm-0.12.1.2-2.253.el6.x86_64
# rpm -qa | grep seabios
seabios-0.6.1.2-15.el6.x86_64
geust info:
guest_name: win7_sp1_64bit

Steps to Reproduce:
1.boot a windows guest.
2."start" -> "control-panel" -> "System and Security" -> "Administrative Tools" -> "Task Scheduler".
3.select "Create Task..." and create a task as following:
  in the "General" tab, fill in "Name" and "Description".
  in the "Triggers" tab, new a trigger, set one time and select "enabled".
  in the "conditions" tab check "Wake the computer to run this task". 
4.suspend guest to memeory.
5.wait for the guest resuming from S3.

Actual results:
after the step 5, the windows 7 guest can not resume from S3 as a response for RTC alarm.

Comment 6 Eduardo Habkost 2012-03-30 12:55:09 UTC
The patch was incorrectly removed on seabios-0.6.1.2-15.el6. Reopening the bug.

Comment 9 Sibiao Luo 2012-04-01 10:37:33 UTC
Reproduced and verified this issue with the following steps:
1.boot a windows guest.
2."start" -> "control-panel" -> "System and Security" -> "Administrative Tools"
-> "Task Scheduler".
3.select "Create Task..." and create a task as following:
  in the "General" tab, fill in "Name" and "Description", check "Run with highest privileges".
  in the "Action" tab, new a action with "Display a message"
  in the "Conditions" tab check "Wake the computer to run this task".
  in the "Triggers" tab, new a trigger, set one time and select "enabled". 
4.suspend guest to memeory.
5.wait for the guest resuming from S3.

Reproduced this issue with the environment and test results as following: 
host info:
# uname -r && rpm -q qemu-kvm
2.6.32-251.el6.x86_64
qemu-kvm-0.12.1.2-2.267.el6.x86_64
# rpm -qa | grep seabios
seabios-0.6.1.2-15.el6.x86_64
geust info:
guest_name: win7_sp1_64bit

Actual results:
after the step 5, the windows 7 guest can not resume from S3 as a response for
RTC alarm.

Verified this issue with the environment and test results as following: 
host info:
# uname -r && rpm -q qemu-kvm
2.6.32-251.el6.x86_64
qemu-kvm-0.12.1.2-2.267.el6.x86_64
# rpm -qa | grep seabios
seabios-0.6.1.2-16.el6.x86_64
geust info:
guest_name: win7_sp1_64bit

Actual results:
after the step 5, the windows 7 guest can resume from S3 as a response for
RTC alarm and display a message as i specified in the step 3.

Above all, this issue has been fixed.

Comment 13 Eduardo Habkost 2012-04-23 18:50:54 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.

Comment 15 errata-xmlrpc 2012-06-20 12:55:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0802.html


Note You need to log in before you can comment on or make changes to this bug.