Bug 80499 - (S3 Trio) VTswitching screen corruption
Summary: (S3 Trio) VTswitching screen corruption
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 82783
TreeView+ depends on / blocked
 
Reported: 2002-12-27 10:49 UTC by Estevao
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-10 16:37:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Config File (3.47 KB, text/plain)
2003-01-24 19:08 UTC, Estevao
no flags Details
Log 1/2 (22.25 KB, text/plain)
2003-01-24 19:10 UTC, Estevao
no flags Details
Log 2/2 (22.47 KB, text/plain)
2003-01-24 19:13 UTC, Estevao
no flags Details

Description Estevao 2002-12-27 10:49:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Hallo.I have downloaded and installed the Red Hat 8.0 Linux. I have the S3 Trio
64 Video Card; it runs correctly BUT when I change the work ambients (using Crl
+ Alt + FX), when I back to the graphical ambient, I see the screen "screwed
up", I don't know how to explain, but always when i change the ambient and back
to the graphic ambient (usually it is in F7 or F8) the screen is just " screwed
up"  and I have to kill X, no chance to work on it. I would like you to please
see this bug.

I had installed already a Red Hat Linux 6.0 and a 7.1 and this not happened. It
only happens now that I've changed to the 8.0 version.

Thanks

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce


Additional info:

Comment 1 Mike A. Harris 2002-12-27 19:32:40 UTC
I'm not familiar with the term "ambients", however it seems that you are
refering to virtual consoles, and switching between them.  Please attach
your XFree86 log file and config file from the failing setup.

Comment 2 Mike A. Harris 2003-01-15 12:29:29 UTC
Awaiting requested file attachments before investigating issue...

Comment 3 Estevao 2003-01-15 17:16:51 UTC
In the Log files, EVERYTHING is ok.

I solved this bug pressing [Ctrl, Alt +] simultaneously when I back to X11 
virtual console. I don't know exactly what it does, i think it changes the 
screen. I need to change 6 times to back to the normal screen.

PS: It only worked with resolutions HIGHER than 1024x768.

Everything seems to be ok in the log files, but as I said when I try to change 
the virtual consoles and back to the x11's console, the screen seems to be 
totally "messed". The screen is higher and discolated to the right side, like 
90% of the screen that appears in my Monitor is black and 10% is a part of the 
x11's screen. So I need to always press [Ctrl, Alt, + ]; it adjusts the screen, 
but it only works as i said with resolutions higher than 1024x768.

So please check this.

My hardware:

S3 Trio 64 video card
Monitor Phlips 107s frequences:
Horizontal: 30-70
Vertical: 50-160

It just happens in RedHat Linux versions higher than the 7.1 (I tested that in 
the 7.3 and in the 8.0, but i don't know about the version 7.2).

And the way to solve that is pressing 6 times [Ctrl, Alt, + ], but this way 
only works with screen resolutions higher than 1024x768.

In the log files, everything seems to be normal. * But it isn't huh? *

Thanks for the attention.

Comment 4 Mike A. Harris 2003-01-23 12:18:29 UTC
Please attach your XFree86 log file and config file from the failing setup
as has been requested above.

These are *required* in order to fix the problem, regardless of what might
look useful or not, without those files, there is absolutely nothing that
I can do about this problem.  I need this information as soon as possible,
or this problem will not be fixed in time for our next release.





Comment 5 Mike A. Harris 2003-01-24 16:27:14 UTC
ping

Comment 6 Mike A. Harris 2003-01-24 16:31:09 UTC
There are hundreds of video cards named "S3 Trio" and not all of them
are the same.  Also, they do not all use the same driver.

Without any further response from you I am unable to fix this problem.
I'm closing this bug as WONTFIX for now.  If you are still interested
however, and can attach the requested information and reopen this report,
I'll be glad to investigate the matter further.


Comment 7 Estevao 2003-01-24 18:15:00 UTC
Well I am sorry because I have just re-installed the Linux RedHat 8.0 now, 
because I was using the version 7.1, the lastest that works with my video card. 
So when I saw your request I had to get the 3 .isos of the RedHat 8.0 and have 
just finished to install now. But if you are still interested I will send my 
log and config files ASAP.

My Video Card is: S3 Trio 32/64

Comment 8 Estevao 2003-01-24 19:08:56 UTC
Created attachment 89585 [details]
Config File

Comment 9 Estevao 2003-01-24 19:10:27 UTC
Created attachment 89586 [details]
Log 1/2

Comment 10 Estevao 2003-01-24 19:13:09 UTC
Created attachment 89587 [details]
Log 2/2

Here they are. And sorry for being late, but as I explained it taked time (1
day) do re-download RedHat 8.0 and installed it.

Comment 11 Mike A. Harris 2003-01-24 21:07:54 UTC
Thanks.

Can you try using the "vesa" driver, and report back if that works for you
or not?  Also, can you supply the output of "lspci -vvn"

Comment 12 Estevao 2003-01-25 03:57:03 UTC
Well, I am still new in Linux so I don't know how to do it...can you explain me 
please?


Note You need to log in before you can comment on or make changes to this bug.