Bug 805024 - Dynamic dividers don't disappear when they're supposed to
Dynamic dividers don't disappear when they're supposed to
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Alex Wood
J.C. Molet
:
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-03-20 09:16 EDT by J.C. Molet
Modified: 2012-06-20 09:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:07:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
divider (271.87 KB, image/png)
2012-03-20 09:16 EDT, J.C. Molet
no flags Details
divider fixed (117.16 KB, image/png)
2012-03-21 12:34 EDT, J.C. Molet
no flags Details

  None (edit)
Description J.C. Molet 2012-03-20 09:16:49 EDT
Created attachment 571408 [details]
divider

Description of problem:
In the Subscription Manager GUI's toolbar, the divider for the "Redeem a Subscription" button doesn't disappear when the icon disappears.  This makes it look like something is broken in the toolbar.

Version-Release number of selected component (if applicable):
subscription-manager-gnome-0.99.10-1.git.80.a5fa07f.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. Start up subscription-manager-gui on a non dell system so that the redeem toolbar button doesn't show up
2. ...
3. profit?
  
Actual results:
You get two dividers with a blank space in between them

Expected results:
You would get only one divider, and the divider to the right of the redeem button would be set to SHOWING=false

Additional info:
see screenshot
Comment 1 Alex Wood 2012-03-20 14:09:46 EDT
Committed 975d2b458f6ba8baa81e8e9dc50aa0808b67d762

subscription-manager-0.99.11+
Comment 3 J.C. Molet 2012-03-21 12:34:49 EDT
Created attachment 571765 [details]
divider fixed

Tested in:

subscription-manager-gnome-0.99.10-1.git.85.057ca98.el6.x86_64

The divider no longer shows when the redeem button isn't showing.

marking VERIFIED.
Comment 5 errata-xmlrpc 2012-06-20 09:07:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.