Bug 805131 - org.fusesource.fusesource-pom is not packaged
org.fusesource.fusesource-pom is not packaged
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: jansi (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marek Goldmann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-20 11:25 EDT by Mary Ellen Foster
Modified: 2012-07-10 06:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-10 06:55:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mary Ellen Foster 2012-03-20 11:25:16 EDT
Description of problem:
The jansi package includes both the jansi POM itself and the jansi-project POM. However, the jansi-project POM refers to a parent POM that is not installed:

  <parent>
    <groupId>org.fusesource</groupId>
    <artifactId>fusesource-pom</artifactId>
    <version>1.5</version>
  </parent>

This means that any attempts to build against jansi using mvn-rpmbuild will fail because they can't find org.fusesource.fusesource-pom.

Version-Release number of selected component (if applicable):
jansi-1.6-2.fc17
Comment 1 Mary Ellen Foster 2012-03-20 11:30:18 EDT
NB: exactly the same issue with hawtjni:


  <parent>
    <groupId>org.fusesource</groupId>
    <artifactId>fusesource-pom</artifactId>
    <version>1.8</version>
  </parent>
Comment 2 Marek Goldmann 2012-06-18 10:00:56 EDT
Mary, there is a package called fusesource-pom containing the requested parent pom. The package is added to BR. Could you please confirm it?
Comment 3 Marek Goldmann 2012-07-10 06:55:05 EDT
I'm closing this since I think the problem doesn't exists anymore. Feel free to reopen it.

Note You need to log in before you can comment on or make changes to this bug.