Bug 805149 - Allow for multiple instances of swift's systemd services
Allow for multiple instances of swift's systemd services
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openstack-swift (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alan Pevec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-20 11:40 EDT by Mark McLoughlin
Modified: 2012-04-11 23:02 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-swift-1.4.8-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-11 23:02:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2012-03-20 11:40:18 EDT
For a "swift all in one" installation, you need multiple instances of the account, container and object servers on the one machine

It should be possible to do e.g.

  $> systemctl start openstack-swift-account@1.service
  $> systemctl start openstack-swift-account@2.service

and have two instances of the account service.

You would also need to have e.g. /etc/swift/account-server/1.conf and /etc/swift/account-server/2.conf

This should just be a matter of adding openstack-swift-account@.service with e.g.

  ExecStart=/usr/bin/swift-account-server /etc/swift/account-server/%i.conf

See the systemd.unit(5) manpage for information about %i and instance names. Also this blog post: http://0pointer.de/blog/projects/instances.html
Comment 1 Mark McLoughlin 2012-03-20 11:42:56 EDT
Forgot to mention that this is actually a regression caused by #734594 and credit goes to Derek Higgins for the idea.
Comment 2 Fedora Update System 2012-03-20 19:05:43 EDT
openstack-swift-1.4.7-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/openstack-swift-1.4.7-2.fc17
Comment 3 Fedora Update System 2012-03-21 14:18:54 EDT
Package openstack-swift-1.4.7-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openstack-swift-1.4.7-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4343/openstack-swift-1.4.7-2.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-03-22 20:43:24 EDT
Package openstack-swift-1.4.8-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openstack-swift-1.4.8-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4343/openstack-swift-1.4.8-1.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-04-11 23:02:01 EDT
openstack-swift-1.4.8-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.