Bug 805196 - mongo error in log "key too large to index"
mongo error in log "key too large to index"
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: z_other (Show other bugs)
2.0.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: James Slagle
Preethi Thomas
: Triaged
Depends On: 795435 805616
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-20 12:28 EDT by James Slagle
Modified: 2012-05-25 10:15 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 795435
Environment:
Last Closed: 2012-05-25 10:15:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Slagle 2012-03-20 12:28:12 EDT
+++ This bug was initially created as a clone of Bug #795435 +++

I see several occurrences of this error in /var/log/mongodb/mongodb.log.

Thu Jun 30 16:32:19 [conn17]  pulp_unittest.packages Btree::insert: key too large to index, skipping pulp_unittest.packages.$description_-1 861 { : "Oauth2 was originally forked from Leah Culver and Andy Smith's oauth.p..." }

It's not specific to this one package, there are lots of references to packages.$description as being too large to index.  I also see occurrences of repos.$packagegroups, probably because that also has a lengthy description.

This has the potential to fill up the mongo log, making it very hard to see errors you might care about, as well as fill up disk space.

We should look at excluding these keys from indexing.

--- Additional comment from jslagle@redhat.com on 2012-03-19 16:58:11 EDT ---

errata.description as well needs to be removed
Comment 1 James Slagle 2012-03-20 12:50:13 EDT
committed to pulp master 39e4843eddb3e31d25e9f1f0c447ae13d1d0064f
Comment 2 James Slagle 2012-03-21 14:03:41 EDT
additional commit to pulp master 2ecd2b4519431ad9b5b9dec93d29369ecb8e9447
Comment 3 Jeff Ortel 2012-04-12 18:59:15 EDT
build: 0.282
Comment 4 Preethi Thomas 2012-04-18 11:14:13 EDT
verified
[root@preethi-el6-pulp ~]# rpm -q pulp
pulp-0.0.283-1.el6.noarch


checked /var/log/mongodb/mongodb.log
Comment 5 Preethi Thomas 2012-05-25 10:15:46 EDT
Pulp v1.1 Release

Note You need to log in before you can comment on or make changes to this bug.