Bug 80526 - Apache refuses to start before beeing configured with apacheconf
Apache refuses to start before beeing configured with apacheconf
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: apacheconf (Show other bugs)
8.0
All Linux
low Severity low
: ---
: ---
Assigned To: Jonathan Blandford
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-27 12:26 EST by Iago Rubio
Modified: 2013-04-02 00:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-27 09:49:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Iago Rubio 2002-12-27 12:26:15 EST
Description of problem:

When I configured Apache Virtual Host directories with apacheconf, it refuses to
start.

It seems a silly bug as it's easy to hand solve, just a sintax error in apache.conf

The problem seems to be in the Virtual Host directories Allow and Deny sentences.

apacheconf miss the 'from' betwen Allow or Deny and the ip mask or hostname.

apache.conf extract before using apacheconf:

 	<Directory "/var/www/html/">
	 	AllowOverride none
 		Allow 10.0.0.
		Deny 0.0.0.0
		Order Allow,Deny
	</Directory> 

When apache parses the first Allow it finshes with error.
Just writing the 'from' sentence it works as spected:

 	<Directory "/var/www/html/">
	 	AllowOverride none
 		Allow from 10.0.0.
		Deny from 0.0.0.0
		Order Allow,Deny
	</Directory> 

Version-Release number of selected component (if applicable):

unknow but my system is updated via up2date .

How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Iago Rubio 2002-12-27 12:32:05 EST
Sorry, I press enter by mistake so I could not finish the bugzilla report.

Continuing...

How reproducible:

setup an Virtual Directory with apacheconf and set the Allow and Deny directives.

Then start apache.

Steps to Reproduce:
1. open apacheconf
2. set a Virtual Host
3. set Allow and Deny directives
    
Actual results:

apache refuses to start

Expected results:

apache starts

Additional info:

no more needed (I supose)
Comment 2 Phil Knirsch 2003-01-27 09:49:02 EST
Fixed in redhat-config-httpd-1.0.1-16 available via rawhide real soon now.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.