Bug 805340 - [abrt] meld-1.5.3-1.fc16: prefs.py:93:__init__:GError: Configuration server couldn't be contacted: D-BUS error: The GConf daemon is currently shutting down.
[abrt] meld-1.5.3-1.fc16: prefs.py:93:__init__:GError: Configuration server c...
Status: CLOSED DUPLICATE of bug 784739
Product: Fedora
Classification: Fedora
Component: meld (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dominic Hopf
Fedora Extras Quality Assurance
abrt_hash:d253d512d5c0981ebee2f61ee21...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-20 19:22 EDT by jharrison
Modified: 2012-03-21 16:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-21 16:06:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: smolt_data (5.40 KB, text/plain)
2012-03-20 19:22 EDT, jharrison
no flags Details

  None (edit)
Description jharrison 2012-03-20 19:22:40 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        python /usr/bin/meld data1.csv data2.csv
event_log:      2012-03-20-17:21:35> Smolt profile successfully saved
executable:     /usr/bin/meld
kernel:         3.2.6-3.fc16.x86_64
reason:         prefs.py:93:__init__:GError: Configuration server couldn't be contacted: D-BUS error: The GConf daemon is currently shutting down.
time:           Tue 28 Feb 2012 02:51:08 PM MST
uid:            1000
username:       james

smolt_data:     Text file, 5533 bytes

backtrace:
:prefs.py:93:__init__:GError: Configuration server couldn't be contacted: D-BUS error: The GConf daemon is currently shutting down.
:
:Traceback (most recent call last):
:  File "/usr/bin/meld", line 138, in <module>
:    main()
:  File "/usr/bin/meld", line 129, in main
:    from meld.meldapp import app
:  File "/usr/share/meld/meld/meldapp.py", line 199, in <module>
:    app = MeldApp()
:  File "/usr/share/meld/meld/meldapp.py", line 113, in __init__
:    self.prefs = preferences.MeldPreferences()
:  File "/usr/share/meld/meld/preferences.py", line 265, in __init__
:    super(MeldPreferences, self).__init__("/apps/meld", self.defaults)
:  File "/usr/share/meld/meld/util/prefs.py", line 93, in __init__
:    self._gconf.add_dir(rootkey, gconf.CLIENT_PRELOAD_NONE)
:GError: Configuration server couldn't be contacted: D-BUS error: The GConf daemon is currently shutting down.
:
:Local variables in innermost frame:
:rootkey: '/apps/meld'
:initial: {'use_custom_font': <meld.util.prefs.Value object at 0xe3a908>, 'statusbar_visible': <meld.util.prefs.Value object at 0xea9440>, 'color_conflict_bg': <meld.util.prefs.Value object at 0xe9eef0>, 'custom_font': <meld.util.prefs.Value object at 0xe3a4d0>, 'color_delete_bg': <meld.util.prefs.Value object at 0xe9ee60>, 'use_syntax_highlighting': <meld.util.prefs.Value object at 0xe3ad40>, 'text_codecs': <meld.util.prefs.Value object at 0xe9ed88>, 'filters': <meld.util.prefs.Value object at 0xea90e0>, 'show_line_numbers': <meld.util.prefs.Value object at 0xe3acb0>, 'spaces_instead_of_tabs': <meld.util.prefs.Value object at 0xe3ac68>, 'color_inline_fg': <meld.util.prefs.Value object at 0xe9ef80>, 'edit_command_custom': <meld.util.prefs.Value object at 0xe3ae18>, 'regexes': <meld.util.prefs.Value object at 0xea9098>, 'tab_size': <meld.util.prefs.Value object at 0xe3ac20>, 'show_whitespace': <meld.util.prefs.Value object at 0xe3acf8>, 'color_inline_bg': <meld.util.prefs.Value object at 0xe9ef38>, 'ignore_blank_lines': <meld.util.prefs.Value object at 0xea93b0>, 'window_size_x': <meld.util.prefs.Value object at 0xe3ae60>, 'window_size_y': <meld.util.prefs.Value object at 0xe3a320>, 'color_replace_bg': <meld.util.prefs.Value object at 0xe9eea8>, 'vc_status_filters': <meld.util.prefs.Value object at 0xea94d0>, 'edit_command_type': <meld.util.prefs.Value object at 0xe3add0>, 'toolbar_visible': <meld.util.prefs.Value object at 0xea93f8>, 'dir_status_filters': <meld.util.prefs.Value object at 0xea9488>, 'edit_wrap_lines': <meld.util.prefs.Value object at 0xe3ad88>, 'ignore_symlinks': <meld.util.prefs.Value object at 0xe9ed40>, 'vc_console_visible': <meld.util.prefs.Value object at 0xe9ee18>}
:self: <meld.preferences.MeldPreferences object at 0xd499d0>
Comment 1 jharrison 2012-03-20 19:22:42 EDT
Created attachment 571562 [details]
File: smolt_data
Comment 2 jharrison 2012-03-21 16:06:26 EDT
I don't believe this is a bug in meld; I've had several problems with GConf shutting down without apparent cause. 

The bug is at the very least a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=784739

*** This bug has been marked as a duplicate of bug 784739 ***

Note You need to log in before you can comment on or make changes to this bug.