This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 805398 - ls does not show ACL information when dereferencing symlinks
ls does not show ACL information when dereferencing symlinks
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
16
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-21 03:12 EDT by Scott K Logan
Modified: 2012-04-14 19:21 EDT (History)
5 users (show)

See Also:
Fixed In Version: coreutils-8.12-7.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-14 19:21:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott K Logan 2012-03-21 03:12:11 EDT
Description of problem:
Using -L should show ACL information with dereferenced symlinks to directories.
Specifically, if ACL information is present on a folder, it's dereferenced symlink should show '+' at the end of the mode.


Version-Release number of selected component (if applicable):
Bug is NOT present in coreutils-8.12-2.fc16
Bug IS present in coreutils-8.12-6.fc16


How reproducible:
100%


Steps to Reproduce:
1. mkdir d
2. ln -s d l
3. setfacl -nm u:daemon:rx d
4. ls -dl -L l
  
Actual results:
Mode shows a '.' at the end, ex drwxrwxr-x.


Expected results:
Mode should show a '+' at the end, ex drwxrwxr-x+


Additional info:
This bug makes it impossible to build the acl RPM, as it causes one of the tests to fail.
Comment 1 Ondrej Vasik 2012-03-21 03:32:56 EDT
Thanks for report - probably caused by fix for https://bugzilla.redhat.com/show_bug.cgi?id=692823 . Seems to work correctly in rawhide and f17 (coreutils-8.15).
Comment 2 Ondrej Vasik 2012-03-21 04:09:31 EDT
Ok confirmed, the fix for 692823 caused the regression in ls ... which was solved by http://git.savannah.gnu.org/gitweb/?p=gnulib.git;a=commitdiff;h=80af92afd10f9ed1c3621432145baf4a32ab5cea . However, upstream reverted both patches, as the commit introduces performance regression in common case for a little gain in uncommon one.
Comment 3 Fedora Update System 2012-03-26 07:27:41 EDT
coreutils-8.12-7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/coreutils-8.12-7.fc16
Comment 4 Fedora Update System 2012-03-30 23:18:53 EDT
Package coreutils-8.12-7.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing coreutils-8.12-7.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5072/coreutils-8.12-7.fc16
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-04-14 19:21:38 EDT
coreutils-8.12-7.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.