Bug 80540 - grub.conf option "root=LABEL=/" causes kernel panic
grub.conf option "root=LABEL=/" causes kernel panic
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Depends On:
  Show dependency treegraph
Reported: 2002-12-27 14:54 EST by Robert P. J. Day
Modified: 2007-04-18 12:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-05-20 05:38:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Robert P. J. Day 2002-12-27 14:54:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
  since 7.3, i've been using a kernel line in grub.conf similar

 kernel /vmlinux... ro root=LABEL=/ hdb=ide-scsi

having labelled /dev/hda1, my root partition, with the
label "/".

  however, since i upgraded to the red hat updates version
of kernel 2.4.20-2.2, specifying my root filesystem using
"LABEL=/" causes the following at boot time:

 VFS: Cannot open root device "LABEL=/" or 00:00
 Please append a correct "root=" option
 kernel panic: VFS: Unable to mount root fs on 00:00

i can get around this by editing the grub kernel line
and substituting "root=/dev/hda1" and it will boot fine.
but this shouldn't be necessary -- the LABEL option has
worked for quite some time until 2.4.20-2.2.

  i have verified that all of the partitions are still
properly labelled, and unique.  in addition, one other 
participant on the redhat mailing list reported exactly
the same error.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. use a "LABEL=/" option in /etc/grub.conf
2. reboot

Actual Results:  should boot properly

Expected Results:  kernel panic, see above

Additional info:
Comment 1 Arjan van de Ven 2002-12-27 18:56:17 EST
does your grub.conf list an initrd ?
Comment 2 Robert P. J. Day 2002-12-27 20:53:54 EST
  never mind, someone else on the redhat list suggested that it was
the lack of an initrd file that was the problem.  apparently, even
though i had all the modules i needed built into the kernel, the
initrd file was still necessary to be able to use a LABEL option
in grub.conf.  without one, it's necessary to use the explicit device name.

  at least, that's the way it looks, and things work fine now.
Comment 3 Martin O'Connor 2003-05-20 05:22:28 EDT
I can boot a custom redhat kernel without initrd if ext3 is compiled into the
kernel. grub.conf has root=LABEL=/.
The problem occurs with non redhat kernels (eg. fresh download from kernel.org).
Perhaps redhat kernels have a certain configuration default which allows labels
to be read?
Comment 4 Arjan van de Ven 2003-05-20 05:38:49 EDT
the kernel doesn't use this. At all.
you HAVE to have an initrd to use LABEL for root.
Comment 5 Gopu Bhaskar 2004-08-04 05:40:00 EDT
I had ext3 compiled into the kernel but still the problem persisted. 
But removing the root=LABEL=/ itself from grub.conf let my box boot 
fully without any issues.

Note You need to log in before you can comment on or make changes to this bug.