Bug 805408 - unresolved dependency for xulrunner
unresolved dependency for xulrunner
Status: CLOSED DUPLICATE of bug 797779
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libproxy (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jiri Skala
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-21 04:27 EDT by Tomas Pelka
Modified: 2014-11-09 17:35 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-26 06:19:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Pelka 2012-03-21 04:27:49 EDT
Description of problem:
In case you have no libproxy-mozjs package on your system xulrunner instalation will fail on unresolved dependency.

It requires libmozjs.so()(64bit).

xulrunner-1.9.2.24-2.el6_1.1 provided this.
xulrunner-10.0.3-1.el6_2 does not. 

Version-Release number of selected component (if applicable):
xulrunner-10.0.3-1.el6_2

How reproducible:
100%

Steps to Reproduce:
1. remove libproxy-mozjs
2. update xulrunner to 10
3.
  
Actual results:
It requires libmozjs.so()(64bit).

Expected results:
libmozjs.so should be in required packages for xulrunner

Additional info:
Comment 1 John W. Lockhart 2012-03-21 13:38:52 EDT
To be more specific, libproxy-mozjs requires libmozjs.so()(64bit).  xulrunner-1.9 provides libmozjs, but xulrunner-10 does not provide libmozjs.

If libproxy-mozjs is present with an old xulrunner, the update to xulrunner-10 will fail because xulrunner-10 no longer provides libmozjs.

If you did not have libproxy-mozjs installed before updating to xulrunner-10, the missing libmozjs in 10 will prevent libproxy-mozjs from being installed.

Note that libproxy-mozjs comes from libproxy.src.rpm.

Expected result:
  libmozjs should be provided by something -- either xulrunner (which used to provide it), or something else.  If libproxy-mozjs is no longer intended to be available, something needs to Obsolete it, or libproxy needs to be updated.
Comment 2 RHEL Product and Program Management 2012-03-26 05:40:05 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.
Comment 3 Jan Horak 2012-03-26 05:44:52 EDT
We can fix that issue just by rebuilding libproxy against xulrunner 10 and changing:
%define gecko_version 1.9.2
to:
%define gecko_version 10.0

I've changed the component to libproxy.
Comment 4 Jan Horak 2012-03-26 06:19:43 EDT

*** This bug has been marked as a duplicate of bug 797779 ***

Note You need to log in before you can comment on or make changes to this bug.