Bug 805411 - [ovirt] [vdsm] Failed to load vm with ISO Image (vm is started and ISO image is dropped) [NEEDINFO]
[ovirt] [vdsm] Failed to load vm with ISO Image (vm is started and ISO image ...
Status: CLOSED DUPLICATE of bug 800253
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Eduardo Warszawski
yeylon@redhat.com
: Regression, TestBlocker
Depends On: 800253
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-21 04:50 EDT by Haim
Modified: 2016-04-18 02:44 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-03 05:50:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
danken: needinfo? (dallen)


Attachments (Terms of Use)

  None (edit)
Description Haim 2012-03-21 04:50:40 EDT
Description of problem:

- vm is started, but ISO image is not loaded due to libvirt bug. 

This issue was introduced with the following patch: 

Adding optional startupPolicy for (file) cdrom and floppy - change: 529ea68bd3d1c99a1b0a58b83b01a029db69a9b0

The problem is originated in libvirt, however, this patch should be reverted till BZ#800253 is resolved.
Comment 1 Dan Kenigsberg 2012-04-01 06:15:42 EDT
Please explain the bug here. CDROM *should* be optional. If it is missing, the VM *should* start anyway.

Please explain why this is a TestBlocker. Which tests are blocked by this? And how come this is Urgent? Please push some pressure on the underlying libvirt bug instead of adding noise to Vdsm.
Comment 2 Haim 2012-04-01 07:30:26 EDT
(In reply to comment #1)
> Please explain the bug here. CDROM *should* be optional. If it is missing, the
> VM *should* start anyway.
> 
> Please explain why this is a TestBlocker. Which tests are blocked by this? And
> how come this is Urgent? Please push some pressure on the underlying libvirt
> bug instead of adding noise to Vdsm.

you are right, vm starts anyway, but without the CD-ROM, the actual bug is on libvirt side, where no matter what, they drop the ISO from XML even if path is accessible.

the reason for this bug is set with TestBlocker flag is because it actually blocking us from testing attach CD flow. 

please note i have already spoke with libvirt guys on several occasions (every 2-3 days to be exact), and currently, they having back-porting issues for the optional CD-ROM feature.
Comment 3 Dan Kenigsberg 2012-04-03 05:50:36 EDT
Dave, please help us here...

*** This bug has been marked as a duplicate of bug 800253 ***

Note You need to log in before you can comment on or make changes to this bug.