Bug 805478 - Unable to use permission-mod to rename permission object
Unable to use permission-mod to rename permission object
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.2
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Rob Crittenden
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-21 08:49 EDT by Namita Soman
Modified: 2013-08-19 10:21 EDT (History)
4 users (show)

See Also:
Fixed In Version: ipa-2.2.0-10.el6
Doc Type: Bug Fix
Doc Text:
Cause: Due to a bug in IPA permission plugin, an attempt to rename a permission always resulted in an error. Consequence: User had to remove the permission and create a new permission with a new name if he wanted to rename the permission. Fix: The bug in IPA permission plugin was fixed. Result: User is able to rename permissions.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:25:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Namita Soman 2012-03-21 08:49:14 EDT
Description of problem:

#ipa permission-mod "Add Automount keys" --rename="AAA" --attr=
ipa: ERROR: This entry already exists


Version-Release number of selected component (if applicable):
ipa-server-2.2.0-4.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. ipa permission-mod "Add Automount keys" --rename="AAA" --attr=

  
Actual results:
ipa: ERROR: This entry already exists

Expected results:
"Add Automount keys" should be renamed to AAA

Additional info:
Comment 2 Dmitri Pal 2012-03-21 10:44:03 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/2571
Comment 3 Rob Crittenden 2012-04-12 15:38:32 EDT
Fixed upstream.

master: 2584e9be673985d530447b836b38cb4ddbf8ee21

ipa-2-2: 04d0215efb2ab9ec73827f2777689aed99d4931e
Comment 8 Martin Kosek 2012-04-25 05:40:46 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: Due to a bug in IPA permission plugin, an attempt to rename a permission always resulted in an error.
Consequence: User had to remove the permission and create a new permission with a new name if he wanted to rename the permission.
Fix: The bug in IPA permission plugin was fixed.
Result: User is able to rename permissions.
Comment 9 Namita Soman 2012-04-26 09:57:13 EDT
Tested using ipa-server-2.2.0-11.el6.x86_64

# ipa permission-show "Add Automount keys"
  Permission name: Add Automount keys
  Permissions: add
  Subtree: ldap:///automountkey=*,automountmapname=*,cn=automount,dc=testrelm,dc=com
  Granted to Privilege: Automount Administrators


Bug 782847 prompts for all parameters.....but will eventually rename the permission

# ipa permission-mod "Add Automount keys" --rename="AAA" 
[Attributes]: 
[Type]: 
[Member of group]: 
[Filter]: 
[Subtree]: 
[Target group]: 
----------------------------------------
Modified permission "Add Automount keys"
----------------------------------------
  Permission name: aaa
  Permissions: add
  Subtree: ldap:///automountkey=*,automountmapname=*,cn=automount,dc=testrelm,dc=com
  Granted to Privilege: Automount Administrators
Comment 11 errata-xmlrpc 2012-06-20 09:25:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0819.html

Note You need to log in before you can comment on or make changes to this bug.