Bug 805562 - Unable to share print queues
Unable to share print queues
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Guenther Deschner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-21 11:29 EDT by Tim Waugh
Modified: 2012-10-15 14:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 12:49:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 8769 None None None 2012-10-15 12:49:25 EDT

  None (edit)
Description Tim Waugh 2012-03-21 11:29:06 EDT
Description of problem:
I am trying to use samba to share a CUPS print queue over SMB.

Version-Release number of selected component (if applicable):
samba-3.6.3-78.fc16.x86_64

How reproducible:
100%

Steps to Reproduce:
1.First, connect a printer and print a test page.
2.Install samba.
3.smbpasswd -a twaugh (and set a password)
4.Now test whether samba can accept jobs. From the command line:

$ smbclient //mymachine/Epson-Stylus-D78 -U twaugh
(enter password)
smb: \> print /etc/fstab
  
Actual results:
NT_STATUS_ACCESS_DENIED opening remote file fstab-6144

Expected results:
File sent to print queue.

Additional info:
Also fails if "guest ok = yes" is set in [printers], and when connecting as a guest i.e. using -N.
Comment 1 Vitaly Lipatov 2012-10-15 14:03:16 EDT
Resolved by Andreas Schneider since 2012-10-08 11:46:16 UTC 
See https://bugzilla.samba.org/show_bug.cgi?id=8769

Note You need to log in before you can comment on or make changes to this bug.