Bug 805566 - [abrt] sssd-1.8.1-8.fc16: strlen: Process /usr/libexec/sssd/sssd_be was killed by signal 11 (SIGSEGV)
[abrt] sssd-1.8.1-8.fc16: strlen: Process /usr/libexec/sssd/sssd_be was kille...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sssd (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephen Gallagher
Fedora Extras Quality Assurance
abrt_hash:21c9db87916257bb512f111130a...
:
: 804783 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-21 11:35 EDT by James Cape
Modified: 2012-04-24 11:02 EDT (History)
5 users (show)

See Also:
Fixed In Version: sssd-1.8.2-10.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-24 11:02:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (5.37 KB, text/plain)
2012-03-21 11:35 EDT, James Cape
no flags Details
Backtrace from another report that was marked as a dup (16.54 KB, application/octet-stream)
2012-03-28 20:15 EDT, James Cape
no flags Details

  None (edit)
Description James Cape 2012-03-21 11:35:50 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/libexec/sssd/sssd_be --domain eladian.com --debug-to-files
comment:        
crash_function: strlen
executable:     /usr/libexec/sssd/sssd_be
kernel:         3.2.10-3.fc16.x86_64
pid:            18862
pwd:            /
reason:         Process /usr/libexec/sssd/sssd_be was killed by signal 11 (SIGSEGV)
time:           Wed 21 Mar 2012 11:30:51 AM EDT
uid:            0
username:       root

backtrace:      Text file, 17056 bytes
dso_list:       Text file, 5494 bytes
maps:           Text file, 25119 bytes

build_ids:
:28579c89bda7f08dace218884d7a5561f3f5f89d
:b06c064de933351790864300dddec868b2a6401e
:ccd23fb93a7924ddd27ea9e7f054fa5309c92f32
:5083c24b4fd7dbf3cac9cf4c15876b0dfdceb4bb
:bb2eda4e80e107a3874f5cf7612166a1d81cd08b
:34e8b3cee73a6d0b8ac17c69ba4b1170724db64c
:ef95ed2b74ff19753827117d4e556f38b33e74b5
:065f24e263b3a0d4316bfeedf855df8c2c35c03a
:59292332bd88fce31f7557e60ff08d44ce254ec8
:b010321c92dc1b5abf0007da423b778542817883
:552354979eebf3d6c27346691a5b520ccf8f4e75
:0ce9819eb7014de7e72eec40979dd5e4d6566dca
:b1532c8fcd1888fb7dc99186b3b8ec6875c72fa4
:9181b91e3dd3b2786bf09199d2f89ec2a27d3652
:77ca13b377dc2850e7bde1c91e160c0f19421fb1
:638db099ff5fb986d1a092629d1bb1dca5be4904
:e5429e0905bedecc534b057783916ba43e06a66e
:d0b5f1b1804ecdb5af0fe6d86e1117b7f377d47b
:2b09b8bb44cdbcce3b7e6a786adb0c0ffb4a27b9
:2639b5594fe4d7897db63ecd1ebb9681438317a8
:83cb4627bed5c756d4e6f23badf8a6b4b042f4e6
:a0b2903547454e47fec356c1fa1a69a7593893c5
:c95e8094ddf00e9e03f98e4bd796b7c60a50d919
:e2e67b3ae2579e1667b73ad385f61552931024e9
:b9746e6e639b060dcd2809a4c46655ee77838bf1
:8ea3a1b50dfbd33351111dac86cb8d6b6a73976f
:3ed9e0f5bbcd8d9d5b77f7dd4b562ec83d7ea767
:ea44661a40777d6be2f79058c161d3bb4962891a
:3903219097bcd7fef6702a8fc24e50484083e23e
:c314e9cb57367719196b6f665fe6773a2d08add6
:4b4285058f7f6b39b7e7c45df83fd36c6833bfe4
:b52ecaab000fad35642f76aaf4396f4e7ae01c45
:dacf32a9a2f2b5077ba944e7b835cca6f637f78f
:186430a109712d3f99c968fdb8d897a7aca2eb77
:2ae4bcf5a249f300d9879500800c546ed525a6dc
:20efc30fde6abc23cfe693739cff23d67ee9d333
:53b01cfc73e8eba8c6af3feefd3f4378439692b9
:0a49b6fd90960659888f0be3bb576495f9d41959
:be507c791e34415e8f42f0e6030c889b2895cf9a
:0bd515c1c778bb4b8f870a900d1543da39d6b662
:14251252341032537663aeb61fc56edf2330e584
:51e3df2e35f101b59291fb3c73f3341bbfc055d3
:c2692dcb73a5877a23c9b3943bb4603ab19168de
:e2d68a0ee0872365dcc8c6640b7cd7b94c8276f2
:82df68f406427a9efe3b2e41cec4374c1faf8dab
:3691cff3e332d944d8ad00a816c50216dab79a34
:b9d3a4213a482d034bebc7dc1ed2901a734a894d
:e814ef8432b7dec42a0b8ec12b9abd9fc7f57b40
:8822ec50a7ca08984b34af0b3096794a5085c473
:08ed61bfccaba5c75792c0cfdb4f64e112acd17c
:caeeab6968f72c5f76b50b0d94ee93db61784288
:5ac56dbb5866c475e1b0c3e4ceeb390b0f7508c0
:1bf947579687b870375bdb51b4eef277f76f9280
:22dcc84f73e86def63c643428320fff70a44a679
:6cfd35e0ead3e8ae8b000a42efe467c28762a08a
:36fc045d11fc55f1b455247938e651666e2c127e
:5cb5f8da286abd58aeab3bd6676e661d52ec2b5d
:1a212c7f1515542b310ba92f6109efc9b5bf2b6e
:ee2f04900ae1f07517d91eba300ef385fccab1b8
:89017ab0b75e533e4294f74ee8f7db3daceea536
:f1e8182609d9eae40a8ddbbb72c9346166014f1a
:96be920f9f506a5bdcb7c4d7a8565b4f0791fc61

environ:
:BOOT_IMAGE=/vmlinuz-3.2.10-3.fc16.x86_64
:PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
:SYSFONT=latarcyrheb-sun16
:LANG=en_US.UTF-8
:PWD=/
:KEYTABLE=us
:_SSS_LOOPS=NO
:KRB5RCACHEDIR=/var/cache/krb5rcache

var_log_messages:
:Mar 20 19:14:50 testslurper1-nyc2 kernel: [  459.179370] sssd_be[2550]: segfault at 80 ip 00007f0ddad5492f sp 00007fffbc049898 error 4 in libc-2.14.90.so[7f0ddac1e000+1ad000]
:Mar 20 19:14:52 testslurper1-nyc2 kernel: [  460.609543] sssd_be[2581]: segfault at 80 ip 00007fe29e51f92f sp 00007fff5f42c348 error 4 in libc-2.14.90.so[7fe29e3e9000+1ad000]
:Mar 20 19:14:53 testslurper1-nyc2 kernel: [  462.486118] sssd_be[2609]: segfault at 80 ip 00007f991d40592f sp 00007fff3a5fd608 error 4 in libc-2.14.90.so[7f991d2cf000+1ad000]
:Mar 20 19:14:55 testslurper1-nyc2 kernel: [  464.097802] sssd_be[2649]: segfault at 80 ip 00007ffbb65e992f sp 00007fff7cfb9f58 error 4 in libc-2.14.90.so[7ffbb64b3000+1ad000]
:Mar 21 11:30:51 testslurper1-nyc2 kernel: [58166.401212] sssd_be[18862] general protection ip:7fee96c1692f sp:7fff9521abe8 error:0 in libc-2.14.90.so[7fee96ae0000+1ad000]
:Mar 21 11:30:51 testslurper1-nyc2 abrt[18868]: Saved core dump of pid 18862 (/usr/libexec/sssd/sssd_be) to /var/spool/abrt/ccpp-2012-03-21-11:30:51-18862 (20828160 bytes)
Comment 1 James Cape 2012-03-21 11:35:53 EDT
Created attachment 571745 [details]
File: dso_list
Comment 2 Stephen Gallagher 2012-03-22 08:14:34 EDT
Please include the backtrace of this crash. I can't tell if it's the same issue as BZ #804783 from this.
Comment 3 James Cape 2012-03-28 20:15:18 EDT
Created attachment 573495 [details]
Backtrace from another report that was marked as a dup
Comment 4 Stephen Gallagher 2012-03-29 07:44:27 EDT
Can you please provide steps to reproduce the issue? I could also use some information about your environment (sssd.conf would be helpful, sanitized as needed).
Comment 5 James Cape 2012-03-29 07:50:45 EDT
[domain/eladian.com]
cache_credentials = True
krb5_store_password_if_offline = True
ipa_domain = <dom>
id_provider = ipa
auth_provider = ipa
access_provider = ipa
chpass_provider = ipa
ipa_server = _srv_, <master>
ldap_tls_cacert = /etc/ipa/ca.crt
ipa_dyndns_update = True
ldap_netgroup_search_base = cn=ng,cn=compat,dc=example,dc=com
enumerate = True
debug_level = 0x77F0
timeout = 1

[sssd]
services = nss, pam
config_file_version = 2
domains = eladian.com

[nss]

[pam]
Comment 6 James Cape 2012-03-29 07:53:47 EDT
Repro steps are

1. Install the new version.
2. Start the new version.
3. Wait 60 seconds.
4. Look to see how many times it's crashed in that interval (usually enough to take it entirely out of commission).

It's running against a freeipa 2.1.4-5 master/slave.
Comment 7 James Cape 2012-03-29 07:54:20 EDT
I should also note that turning enumerate off seems to let it run.
Comment 8 Jakub Hrozek 2012-03-29 13:30:39 EDT
As Stephen suggested on IRC the other day, I could reproduce the bug with enumerate=true but not services to enumerate.
Comment 9 Dmitri Pal 2012-03-29 17:29:28 EDT
Hello James,

Is the enumeration = true a requirement in your environment? When we started the project we very quickly realized that full enumeration would have a lot of scalability issues so we try to discourage everybody from using it. We acknowledge though that there might be some cases where enumeration might be really required though we have not yet came across those. 
So while we are trying to address this issue (which we are committed to addressing anyways) would you be able to move on with your evaluation effort of sssd with the enumeration turned off?

Thank you,
Dmitri
Comment 10 James Cape 2012-03-29 21:47:19 EDT
We're in the process of disabling this feature on all our machines, yes.
Comment 11 abrt-bot 2012-03-30 11:22:01 EDT
*** Bug 804783 has been marked as a duplicate of this bug. ***
Comment 12 Jakub Hrozek 2012-03-30 11:56:52 EDT
Upstream ticket:
https://fedorahosted.org/sssd/ticket/1282
Comment 13 Jakub Hrozek 2012-03-30 12:15:49 EDT
Jason, I think I identified the bug. I build test packages that only include that single fix on top of 1.8.1-8. If you like, you can grab them from koji:
http://koji.fedoraproject.org/koji/taskinfo?taskID=3948204
Comment 14 Fedora Update System 2012-04-09 15:30:52 EDT
sssd-1.8.2-10.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-4404/sssd-1.8.2-10.fc16
Comment 15 Fedora Update System 2012-04-10 23:59:28 EDT
Package sssd-1.8.2-10.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sssd-1.8.2-10.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4404/sssd-1.8.2-10.fc16
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2012-04-24 11:02:06 EDT
sssd-1.8.2-10.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.