Bug 805785 - misc issues of rhel6 kexec-tools which need be ported
misc issues of rhel6 kexec-tools which need be ported
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Baoquan He
Fedora Extras Quality Assurance
:
Depends On: 876483 877253 877261
Blocks: RHEL7KdumpTracker
  Show dependency treegraph
 
Reported: 2012-03-22 02:13 EDT by Dave Young
Modified: 2013-03-18 05:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-18 05:21:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Young 2012-03-22 02:13:10 EDT
Description of problem:

Misc issues which include:
handle selinux, xen, resettable problem, doc and translation, and other things

Related rhel6 bzs:
- selinux
bz[selinux issue?] 612822,"cannot enter user-space to capture vmcore
because the rootfs

- cciss related issues and resettable issue
bz692685,"Provide an option to override the ""resettable"" parameter, and
bz674893,"disable kdump on certain SmartArray (hpsa/cciss) adapters"
O 573624,"kdump does not work with cciss driver"

- xen issues
bz608320,"[RHEL6] disable kdump service inside xen-guest"
bz628817,"[RHEL6] disable kdump service inside xen-guest"
bz627747,"Snapshot 13 fails to install on xen due to kexec-tools"

-translation
O 589214,"[kexec-tools][ALL_LANG] Translation updates"
O 619744,"[kexec-tools] POT file outdated"
O 626318,"[kdump] untranslated string"
O 630305,"[firstboot][ml_IN] - Translation Short-cuts are inconsistent,
O 630309,"[kexec-tools][ml_IN] Translation problem and keyboard Selection

-core_collector
O 611614,"cp doesn't get into initrd when being used as core_collector"
O [core_collector] 652191,"'core_collector cp' causes vmcore being named
vmcore.flat though
O bz614303,"ssh dump doesn't work with 'cp' core_collector"

-misc
O 727892,"kexec-tools: Warn a user to use maxcpus=1 instead of nr_cpus=1
O 605717,"disable memory cgroups on kdump"
O 607195,"add warning to user if running kernel uses more than %60 percent
O 627118,"SharedLibTest failure"
O bz600600,"kdump fails with I/O load on aic7xxx or megaraid_mbox"
O bz585332,"[RHEL6] Add coordination between Kdump and Cluster Fencing for
O bz681796,"Pass ""noefi acpi_rsdp=X"" to the second kernel"
O bz[adding iommu=off] 619338,"oom killer triggered when dumping on AMD
  Magny-Cours"
O bz594058,"[6.0] options command cannot be specified in /etc/kdump.conf."

-mem trace
O [mem debug]604808,"kexec-tools: Output memory usage stats during kdump
boot"
O 734528,"kexec-tools: Add memory usage debugging capability in second
kernel"

- makedumpfile [does it works with latest kernel?]
bz574370,"makedumpfile failed to compress the vmcore file with -c -d 31 on
bz683735,"Makedumpfile fails to recover the raw dump file"


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Fedora Admin XMLRPC Client 2012-04-16 02:12:06 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Dave Young 2012-08-31 03:52:23 EDT
Revisit these bzs, comments below

(In reply to comment #0)
> Description of problem:
> 
> Misc issues which include:
> handle selinux, xen, resettable problem, doc and translation, and other
> things
> 
> Related rhel6 bzs:
> - selinux
> bz[selinux issue?] 612822,"cannot enter user-space to capture vmcore
> because the rootfs
> 

Not valid

> - cciss related issues and resettable issue
> bz692685,"Provide an option to override the ""resettable"" parameter, and
> bz674893,"disable kdump on certain SmartArray (hpsa/cciss) adapters"
> O 573624,"kdump does not work with cciss driver"

Need address

> 
> - xen issues
> bz608320,"[RHEL6] disable kdump service inside xen-guest"
> bz628817,"[RHEL6] disable kdump service inside xen-guest"
> bz627747,"Snapshot 13 fails to install on xen due to kexec-tools"

Probably need address

> 
> -translation
> O 589214,"[kexec-tools][ALL_LANG] Translation updates"
> O 619744,"[kexec-tools] POT file outdated"
> O 626318,"[kdump] untranslated string"
> O 630305,"[firstboot][ml_IN] - Translation Short-cuts are inconsistent,
> O 630309,"[kexec-tools][ml_IN] Translation problem and keyboard Selection

Need address

> 
> -core_collector
> O 611614,"cp doesn't get into initrd when being used as core_collector"
> O [core_collector] 652191,"'core_collector cp' causes vmcore being named
> vmcore.flat though
> O bz614303,"ssh dump doesn't work with 'cp' core_collector"

Resolved

> 
> -misc
> O 727892,"kexec-tools: Warn a user to use maxcpus=1 instead of nr_cpus=1

Not valid

> O 605717,"disable memory cgroups on kdump"

Resolved

> O 607195,"add warning to user if running kernel uses more than %60 percent

Need Address

> O 627118,"SharedLibTest failure"

We do not have mount root and enter user space now, should remove related code
Also should address the binary install hierarchy, install makedumpfile maybe vmcore-dmsg to /usr/sbin/ 

> O bz600600,"kdump fails with I/O load on aic7xxx or megaraid_mbox"

Need address this to avoid probe ide cdrom

> O bz585332,"[RHEL6] Add coordination between Kdump and Cluster Fencing for

Need address, there's another bug for this fencing setup

> O bz681796,"Pass ""noefi acpi_rsdp=X"" to the second kernel"

There's another bug for this as well

> O bz[adding iommu=off] 619338,"oom killer triggered when dumping on AMD
>   Magny-Cours"

iommu issue, how can we do this in rhel7?

> O bz594058,"[6.0] options command cannot be specified in /etc/kdump.conf."
> 

kernel module options override?

> -mem trace
> O [mem debug]604808,"kexec-tools: Output memory usage stats during kdump
> boot"
> O 734528,"kexec-tools: Add memory usage debugging capability in second
> kernel"

Need address for debug purpose

> 
> - makedumpfile [does it works with latest kernel?]
> bz574370,"makedumpfile failed to compress the vmcore file with -c -d 31 on
> bz683735,"Makedumpfile fails to recover the raw dump file"

Resolved or not valid for fedora

> 
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1.
> 2.
> 3.
>   
> Actual results:
> 
> 
> Expected results:
> 
> 
> Additional info:
Comment 3 Dave Young 2012-09-11 02:22:30 EDT
> 
> > O bz[adding iommu=off] 619338,"oom killer triggered when dumping on AMD
> >   Magny-Cours"
> 
> iommu issue, how can we do this in rhel7?
> 

This can be skipped as well, it's just recommending use to user iommu=off
Comment 4 Dave Young 2012-09-12 04:24:57 EDT
> > O bz594058,"[6.0] options command cannot be specified in /etc/kdump.conf."
> > 
> 
> kernel module options override?

I prefer suggest user to add module.options in KDUMP_COMMANDLINE_APPEND, see bz 853003 for details
Comment 5 Dave Young 2012-09-12 04:26:17 EDT
>> O bz681796,"Pass ""noefi acpi_rsdp=X"" to the second kernel"

>There's another bug for this as well

the new bz is 849650, this is not needed in upstream kernel, will close once fedora get kernel update.
Comment 6 Dave Young 2012-09-12 22:22:39 EDT
Another issue need handle:

do not dump to crypted device
Comment 7 Dave Young 2012-11-15 23:59:30 EST
Cloned below two bugs:

Bug 877253 - [RHEL6.2 BETA1] Kdump is not able to capture vmcore when "/" partition is encrypted . (edit) 

Bug 877261 - add warning to user if running kernel uses more than %60 percent of reserved crashkernel memory amount (edit)

Chao wang created below:
Bug 876483 - disable kdump on certain SmartArray (hpsa/cciss) adapters
Comment 8 Fedora Admin XMLRPC Client 2013-02-25 03:07:03 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 Fedora Admin XMLRPC Client 2013-02-25 03:09:42 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Note You need to log in before you can comment on or make changes to this bug.