Bug 805801 - via-rhine doesn't work anymore in kernel-PAE-3.3.0-4.fc16
via-rhine doesn't work anymore in kernel-PAE-3.3.0-4.fc16
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-22 03:52 EDT by Michael Weidner
Modified: 2012-04-22 00:15 EDT (History)
8 users (show)

See Also:
Fixed In Version: kernel-3.3.2-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 15:30:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output of kernel 3.2.10-3.fc16 (45.02 KB, application/octet-stream)
2012-03-22 03:52 EDT, Michael Weidner
no flags Details
dmesg output of kernel 3.3.0-4.fc16 (42.97 KB, application/octet-stream)
2012-03-22 03:53 EDT, Michael Weidner
no flags Details
output of "lcpci -v" (8.95 KB, application/octet-stream)
2012-03-22 03:53 EDT, Michael Weidner
no flags Details

  None (edit)
Description Michael Weidner 2012-03-22 03:52:17 EDT
Created attachment 571927 [details]
dmesg output of kernel 3.2.10-3.fc16

Description of problem:

In the new kernel version kernel-PAE-3.3.0-4.fc16 the via-rhine module does not work correct.

Autonegation isn't working anymore, this is shown in log when inserting a LAN cable:

[   30.814449] NOHZ: local_softirq_pending 08

Then allways a 10MBit Halfduplex connection is shown with ethtool and mii-tool.

When trying a change manualy to 100Mbit with ethtool the connection somtimes is lost completely.

"mii-tool -r" also leeds to a loss of connection.

Also the connection is very, very slow (about 1-2 MBit/s at maximum).

Powertop also shows about 10000 to 20000 pkts/s for via-rhine, in kernel-PAE-3.2.10-3.fc16 the maximum I have seen was about 10-20% of this.

kload also is very very high, about 15-20 and increasing more and more.

This is the dmesg-output of how via-rhine is detected with 3.2.10-3.fc16:

[   17.472960] via-rhine 0000:03:05.0: PCI INT A -> GSI 20 (level, low) -> IRQ 20
[   17.477840] via-rhine 0000:03:05.0: eth1: VIA Rhine II at 0xfebffc00, 00:05:5d:a3:4a:1a, IRQ 20
[   17.478586] via-rhine 0000:03:05.0: eth1: MII PHY found at address 8, status 0x782d advertising 01e1 Link 45e1
[   24.527749] via-rhine 0000:03:05.0: eth1: link up, 100Mbps, full-duplex, lpa 0x45E1

And this of the faulty 3.3.0-4.fc16 (this is all, why so much less? Somethings going completely wrong with this kernel I think):

 [   15.158670] via-rhine 0000:03:05.0: eth1: VIA Rhine II at 0xfebffc00, 00:05:5d:a3:4a:1a, IRQ 20


dmesg output of kernel 3.3.0-4.fc16, dmesg output of kernel 3.2.10-3.fc16 and output of "lspci -v" is attached.

Switching back to 3.2.10-3.fc16 solves the problem.

Version-Release number of selected component (if applicable):

kernel-PAE-3.3.0-4.fc16

How reproducible:

every time with kernel 3.3.0-4.fc16 

Steps to Reproduce:
1. Boot with kernel 3.3.0-4.fc16
Comment 1 Michael Weidner 2012-03-22 03:53:06 EDT
Created attachment 571928 [details]
dmesg output of kernel 3.3.0-4.fc16
Comment 2 Michael Weidner 2012-03-22 03:53:38 EDT
Created attachment 571929 [details]
output of "lcpci -v"
Comment 4 Michael Weidner 2012-04-11 01:47:56 EDT
(In reply to comment #3)
> Can you try:
> 
> http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=blob_plain;f=drivers/net/ethernet/via/via-rhine.c;hb=3f8c91a7398b9266fbe7abcbe4bd5dffef907643
> 
> -- 
> Ueimor

Thanks for your help, but in the meanwhile I have moved to Oracle Linux.They opened their public yum for updates last week or so and this was the time for me to say good bye to Fedora. 

Since Fedora 14 (this was the last good and stable release in my opinion), Fedora is only a buggy on the edge software and nothing for even a home server. 

Mikel
Comment 5 Josh Boyer 2012-04-11 08:42:38 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > Can you try:
> > 
> > http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=blob_plain;f=drivers/net/ethernet/via/via-rhine.c;hb=3f8c91a7398b9266fbe7abcbe4bd5dffef907643
> > 
> > -- 
> > Ueimor
> 
> Thanks for your help, but in the meanwhile I have moved to Oracle Linux.They
> opened their public yum for updates last week or so and this was the time for
> me to say good bye to Fedora. 

If you're still willing to try a recent kernel, I can create a scratch build with the patch linked to above.  Moving to another distro (regardless of which) with an older kernel isn't actually a solution for your problem.  It's just avoiding a bug you (or someone else) will need to have fixed eventually anyway.

Without someone to recreate the issue and test, this bug will eventually get closed out as we don't have the hardware ourselves.
Comment 6 Michael Weidner 2012-04-11 09:21:18 EDT
Hi,

Thanks again, but the problem is also (beside the fact, I have no Fedore installed anymore), I do not have the hardware anymore because I installed a new NIC because of this bug short ago (because nobody was interessted in my bug report, no one assigned it or had a question). I swapped the NIC with one of a friends Windows PC.

This was before I knew of the DVB-S bug in the new kernels (3.3.0-4 and above). If I knew that, I stayed on Kernel < 3.3.0-4 and kept my good old NIC.

I was working with Redhat and Fedora since Redhat 4.0 (after my SLS and Slackware time) and never ever had another distro installed since then, but at the moment (and with two little children at home) I don't have the time and passion to test if erverything is still working after an update of a package.

Michael
Comment 7 Francois Romieu 2012-04-11 10:32:54 EDT
(In reply to comment #5)
[...]
> Without someone to recreate the issue and test, this bug will eventually get
> closed out as we don't have the hardware ourselves.

This issue and 809512 look like duplicate.

Imho [*] it's mostly a matter of checking for post 3.3 3f8c91a7398b9266fbe7abcbe4bd5dffef907643
commit from Linus' tree in the stable branches. David M. has been notified and takes care of feeding it
to -stable.

Anyway Fedora testers will be more than welcome to - especially as I felt a bit lonely with a single PC-like
soekris board tester during the 3.3 cycle :o/

[*] Aka "Guess who is responsible for the latest via-rhine breakage in mainline ?"

-- 
Ueimor
Comment 8 Igor 2012-04-15 01:33:29 EDT
Hi,

I have the same problem.
I've got Ethernet controller: VIA Technologies, Inc. VT6105/VT6106S [Rhine-III] (rev 8b). Kernel - 3.3.1-2.fc16.i686.PAE.
My NIC on this kernel always have speed 10 Mb/s half duplex and I can't change it using ethtool. I have also got Archlinux (3.3.1-1-ARCH) and Mint (3.0.0-12-generic) on my computer and NIC is working perfectly there -100 Mb/s full duplex.

I have tried to make new via-rhine module using 
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=blob_plain;f=drivers/net/ethernet/via/via-rhine.c;hb=3f8c91a7398b9266fbe7abcbe4bd5dffef907643
but when loading it I have error 
via-rhine 0000:03:01.0: Insufficient PCI resources, aborting

It seems that the problem is not with via-rhine driver but with kernel.
Comment 9 Igor 2012-04-15 04:45:27 EDT
I tried Archlinux (3.3.1-1-ARCH) again and NIC is not working properly any more. Symptoms are the same. It seems I upgraded to new kernel last time I used it. The LinuxMint with kernel 3.0.0-12-generic is still working fine.
Comment 10 Francois Romieu 2012-04-15 18:46:25 EDT
(In reply to comment #9)
> I tried Archlinux (3.3.1-1-ARCH) again and NIC is not working properly any
> more. Symptoms are the same. It seems I upgraded to new kernel last time I used
> it. The LinuxMint with kernel 3.0.0-12-generic is still working fine.

The insufficient PCI resources message makes little sense. I hope it's more a
symptom of a temporarily f*cked up network chipset than anything else.

You should imho test something 3.3.2 based.

-- 
Ueimor
Comment 11 Igor 2012-04-16 10:59:10 EDT
(In reply to comment #10)
 (In reply to comment #9)

> You should imho test something 3.3.2 based.

I have done that:
1. Tested again Archlinux 3.3.1-1 - NIC didn't work.
2. Updated Archlinux to 3.3.2-1 - and it's OK now - 100Mb/s full duplex.

 
Thanks for your help, will wait 3.3.2 on Fedora.

Igor
Comment 12 Josh Boyer 2012-04-16 11:04:11 EDT
(In reply to comment #11)
> (In reply to comment #10)
>  (In reply to comment #9)
> 
> > You should imho test something 3.3.2 based.
> 
> I have done that:
> 1. Tested again Archlinux 3.3.1-1 - NIC didn't work.
> 2. Updated Archlinux to 3.3.2-1 - and it's OK now - 100Mb/s full duplex.
> 
> 
> Thanks for your help, will wait 3.3.2 on Fedora.

It's built.  Just not submitted as an update yet.

http://koji.fedoraproject.org/koji/buildinfo?buildID=313130
Comment 13 Fedora Update System 2012-04-16 15:07:05 EDT
kernel-3.3.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.3.2-1.fc16
Comment 14 Fedora Update System 2012-04-16 15:10:28 EDT
kernel-3.3.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.3.2-1.fc17
Comment 15 Fedora Update System 2012-04-16 17:57:00 EDT
Package kernel-3.3.2-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.3.2-1.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5994/kernel-3.3.2-1.fc17
then log in and leave karma (feedback).
Comment 16 Igor 2012-04-17 10:52:01 EDT
(In reply to comment #15)
> Package kernel-3.3.2-1.fc17:
> * should fix your issue,
> * was pushed to the Fedora 17 testing repository,
> * should be available at your local mirror within two days.
> Update it with:
> # su -c 'yum update --enablerepo=updates-testing kernel-3.3.2-1.fc17'
> as soon as you are able to, then reboot.
> Please go to the following url:
> https://admin.fedoraproject.org/updates/FEDORA-2012-5994/kernel-3.3.2-1.fc17
> then log in and leave karma (feedback).

I have done that and my problem is fixed - NIC is working properly - 100Mb/s full duplex.

Igor
Comment 17 Fedora Update System 2012-04-18 15:30:03 EDT
kernel-3.3.2-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2012-04-22 00:15:07 EDT
kernel-3.3.2-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.