Bug 805804 - Doesn't draw properly in a virtual machine
Doesn't draw properly in a virtual machine
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-22 04:11 EDT by Milan Crha
Modified: 2012-04-12 05:03 EDT (History)
3 users (show)

See Also:
Fixed In Version: mesa-8.0.2-2,gdm-3.4.0.1-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-12 05:03:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdm-f17-vm (36.02 KB, image/png)
2012-03-22 04:11 EDT, Milan Crha
no flags Details

  None (edit)
Description Milan Crha 2012-03-22 04:11:23 EDT
Created attachment 571932 [details]
gdm-f17-vm

I have installed Fedora 17, up to date as of yesterday, and since its very beginning the gdb doesn't draw properly (see attached screenshot). The same error does gnome-shell, thus I run a fallback mode. The installation is done in a virtual machine on Fedora 16. What details are you interested in?
Comment 1 Matthias Clasen 2012-04-11 20:13:58 EDT
What graphics ?
Comment 2 Milan Crha 2012-04-12 02:54:46 EDT
The Virtual Machine says:
   VESA: VGABIOS Cirrus extension
while the host says:
   Intel® Ironlake Mobile
(both took from System Info dialog)
Comment 3 Milan Crha 2012-04-12 03:13:54 EDT
Err, I did a 'yum update' on my F17 VM and I cannot login into gdm any more, I just get a black screen and all but TTY1 gives me the same black screen, no login prompt. The TTY1 shows only the bar of loaded F17 and nothing else:

  XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX  Fedora 17

this is getting better and better :-/
Comment 4 Milan Crha 2012-04-12 05:03:11 EDT
OK, after some investigation, the yum update brought in mesa-8.0.2-2.fc17 and gdm-3.4.0.1-4.fc17, apart of kernel and couple other packages. I thought it's due to mesa, thus I downgraded it (not that it was easy), but no, still black screen. Then I downgraded gdm and I got working login screen, even with the background being painted as expected. I tried to install gdm-3.4.0.1-5.fc17 too (it's not part of yum repos for me yet), and it worked too, thus I would say the combination of mesa-8.0.2-2.fc17 and gdm-3.4.0.1-5.fc17 makes this work again.

Note You need to log in before you can comment on or make changes to this bug.