Bug 805806 - system-config-network crashed with python UnicodeDecodeError if use LANG=ru_RU.utf8
system-config-network crashed with python UnicodeDecodeError if use LANG=ru_R...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-network (Show other bugs)
5.8
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Harald Hoyer
Branislav Blaškovič
:
Depends On:
Blocks: 1049888
  Show dependency treegraph
 
Reported: 2012-03-22 04:22 EDT by Semen Soldatov
Modified: 2014-09-15 20:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Early versions of the Python programming language do not switch to the UTF-8 format correctly. This behavior led to a failure of the system-config-network service when some UTF-8 character were present in configuration files. With this update, system-config-network now resets the Python internals to properly handle UTF-8 so that system-config-network no longer crashes in the described scenario.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-15 20:18:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Semen Soldatov 2012-03-22 04:22:32 EDT
Description of problem:
program crashed with python UnicodeDecodeError

Version-Release number of selected component (if applicable):

system-config-network 1.3.99.21
python 2.4

How reproducible:
always

Steps to Reproduce:
1. type in shell: LANG=ru_RU.utf8 network-config-network

  
Actual results:
Exception

Expected results:
run device editor

Additional info:
None
Comment 3 Branislav Blaškovič 2014-05-14 09:11:55 EDT
# LANG=ru_RU.utf8 system-config-network
# rpm -q system-config-network
system-config-network-1.3.99.22-1.el5

This works.

VERIFIED
Comment 5 errata-xmlrpc 2014-09-15 20:18:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1195.html

Note You need to log in before you can comment on or make changes to this bug.