Bug 80585 - Nautilus doesn't work when using stock 2.4.20 kernel
Nautilus doesn't work when using stock 2.4.20 kernel
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: nautilus (Show other bugs)
phoebe
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-28 07:21 EST by Felipe Alfaro Solana
Modified: 2015-01-07 19:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-01 00:19:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Linux config (22.08 KB, text/plain)
2002-12-28 07:23 EST, Felipe Alfaro Solana
no flags Details
Sample grub.conf (714 bytes, text/plain)
2002-12-28 07:24 EST, Felipe Alfaro Solana
no flags Details

  None (edit)
Description Felipe Alfaro Solana 2002-12-28 07:21:44 EST
Description of problem:
-----------------------
I have downloaded, compiled and booted using a stock linux 2.4.20 kernel
compiled with custom options summarized in the "config-2.4.20" file attached to
this bug report.

Whenever I start an X session (logging on through GDM or using a remote
session), the nautilus desktop doesn't come up. Instead, the desktop is not
drawn (on remote sessions, it's the initial gray dotted that the X server draws
when launched up) while nautilus keeps consuming 100% of the CPU time and,
sometimes, crashes. Memory consuptiom stays steadily at 2.7% as reported by  the
top command. As of this bug report, my nautilus process has consumed 7:34 of CPU
time without doing nothing.

When using the standard RedHat Linux 2.4.20-2.2, nautilus works as expected.

This problem can be reproduced using any user on the system: a user which has
never ever used GNOME (has no .gconf .gconfd or .gnome directories) or a user
which uses GNOME normally when booting with the RedHat linux kernel.

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
nautilus-2.1.5-2.i386.rpm (Phoebe)

How reproducible:
-----------------
Always


Steps to Reproduce:
-------------------
1. Download stock 2.4.20 kernel from ftp://ftp.kernel.org
2. Compile the kernel using configuration options from the "config-2.4.20" file
attached to this bug report.
3. Manually install the kernel by moving "arch/i386/boot/bzImage" to
"/boot/vmlinuz-2.4.20", "System.map" to "/boot/System.map-2.4.20", "vmlinux" to
"vmlinux-2.4.20" and ".config" to "/boot/config-2.4.20".
4. Next, update "/etc/grub.conf" in a similar fashion as listed within
"grub.conf" attached to this bug report.
5. Boot using the stock 2.4.20 kernel into runlevel 5, log on to X and wait for
nautilus to come up and draw the desktop. In my case, this won't happen.
    
Actual results:
---------------
Nautilus hangs just before drawing the desktop and keeps consuming the 100% of
the CPU time. Sometimes, it crashes.

Expected results:
-----------------
Nautilus should work properly when using a stock 2.4.20 kernel.

Additional info:
----------------
- I have changed my window manager to Sawfish (instead of metacity which I
personally hate).
- It doesn't seem a user-specific config problem as this problem can be
reproduced either with a normal user or "root".
- Stock kernel was compiled with AGP support and DRI XFree driver for Matrox G200.
- Console is running on MGA G200 framebuffer instead of text-mode.
- Please, contact me for exact repro scenario.
Comment 1 Felipe Alfaro Solana 2002-12-28 07:23:15 EST
Created attachment 88955 [details]
Linux config
Comment 2 Felipe Alfaro Solana 2002-12-28 07:24:31 EST
Created attachment 88956 [details]
Sample grub.conf
Comment 3 Felipe Alfaro Solana 2002-12-28 10:12:03 EST
I've been thinking about this... Is it possible that native Posix threads are
the cause of this issue? Maybe Nautilus was compiled to use native posix threads
library... I think stock 2.4.20 kernel lacks support for this, doesn't it? So
maybe this is the culprit of the problem.
Comment 4 Paul W. Frields 2002-12-31 09:58:50 EST
The Red Hat stock kernel 2.4.20-2.2 starts with the 2.4.20 vanilla kernel but is
patched liberally to provide extended facilities, using code from both the
kernel.org and the Alan Cox trees, plus some work done in-house. To see what's
been changed, install the kernel-2.4.20-2.2.src.rpm and check out all the patches.

It is probably unreasonable to expect some portions of the Red Hat Linux product
to work without a Red Hat packaged kernel. This subject is covered ad nauseum in
the Usenet newsgroups, and a Web search will probably yield myriad results
detailing the travails of those who try to shoehorn a vanilla kernel into their
Red Hat systems. The Red Hat kernel package is one of the major value-added
portions of their Linux product, and abandoning it for a vanilla kernel does
not, ultimately, provide good value for the user. However, as with all Linux
kernels, you are free to do whatever you want, and that includes opening up the
Red Hat packaged kernel, playing with it, changing it, undoing (or redoing)
patches, and making your own.

Paul W. Frields, RHCE/RHCX   (not a full-time Red Hat employee)
Comment 5 Bill Nottingham 2003-01-01 00:19:47 EST
Expected, as currently glibc uses NPTL by default, which depends on features in
the Red Hat 2.4.20 kernel.

Note You need to log in before you can comment on or make changes to this bug.