Bug 805893 - qcow2: triggered assertion in qcow2_cache_destroy()
qcow2: triggered assertion in qcow2_cache_destroy()
Status: CLOSED DUPLICATE of bug 798857
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
medium Severity high
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-22 07:35 EDT by Golita Yue
Modified: 2012-04-13 10:07 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-12 06:29:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
qemu-img error info (4.48 MB, text/plain)
2012-03-22 07:38 EDT, Golita Yue
no flags Details

  None (edit)
Description Golita Yue 2012-03-22 07:35:04 EDT
Description of problem:
start guest with -no-shutdown,
Send 'quit' command via monitor, qemu-kvm core dumped with following info:
qemu: block/qcow2-cache.c:69: qcow2_cache_destroy: Assertion `c->entries[i].ref == 0' failed.

use qemu-img check guest_image got following info, the details pls refer to attachment:
77 errors were found on the image.
Data may be corrupted, or further writes to the image may corrupt it.
50461 leaked clusters were found on the image.
This means waste of disk space, but no harm to data.
30 internal errors have occurred during the check.
An error has occurred during the check: Success
The check is not complete and may have missed error.
ERROR OFLAG_COPIED: l2_offset=14 refcount=1
[stderr] ERROR l2_offset=14: Table is not cluster aligned; L1 entry corrupted
[stderr] Warning: cluster offset=0x1000000000 is after the end of the image file, can't properly check refcounts.

Version-Release number of selected component (if applicable):
kernel-2.6.32-251.el6.x86_64
qemu-kvm-0.12.1.2-2.251.el6.x86_64

How reproducible:
hard to reproduce, hit it only once

Steps to Reproduce:
0. boot vm with -no-shutdown
1. install a vm, poweroff it after installation
2. quit vm with monitor command 'quit'
  
Actual results:
qemu-kvm core dumped with "qemu: block/qcow2-cache.c:69: qcow2_cache_destroy: Assertion `c->entries[i].ref == 0' failed."

Expected results:
no core dump and work well.

Additional info:
1. Attached the full qemu-img log info.

2. Host info:
mem info:
# free -m
             total       used       free     shared    buffers     cached
Mem:         11776       6783       4993          0         69       5068
-/+ buffers/cache:       1646      10130
Swap:        16383          0      16383

cpu info:
processor	: 7
vendor_id	: GenuineIntel
cpu family	: 6
model		: 26
model name	: Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz
stepping	: 4
cpu MHz		: 1600.000
cache size	: 8192 KB
physical id	: 0
siblings	: 8
core id		: 3
cpu cores	: 4
apicid		: 7
initial apicid	: 7
fpu		: yes
fpu_exception	: yes
cpuid level	: 11
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt lahf_lm ida dts tpr_shadow vnmi flexpriority ept vpid
bogomips	: 5319.07
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

3. cmd to boot vm:
qemu-kvm -drive file='RHEL-Server-5.7-64.qcow2',index=0,if=none,id=drive-ide0-0-0,media=disk,cache=none,format=qcow2,aio=threads -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -device e1000,netdev=id2MZdQJ,mac=9a:6b:9f:a6:8e:67,id=ndev00id2MZdQJ,bus=pci.0,addr=0x3 -netdev tap,id=id2MZdQJ,fd=23 -m 6144 -smp 8,cores=4,threads=1,sockets=2 -drive file='RHEL-Server-5.7-x86_64-DVD.iso',index=1,if=none,id=drive-ide0-0-1,media=cdrom,readonly=on,format=raw -device ide-drive,bus=ide.0,unit=1,drive=drive-ide0-0-1,id=ide0-0-1 -drive file='rhel57-64/ks.iso',index=2,if=none,id=drive-ide0-1-0,media=cdrom,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -cpu cpu64-rhel6,+sse2,+x2apic -device usb-tablet,id=usb-tablet1,bus=usb1.0 -kernel 'vmlinuz' -initrd 'initrd.img' -spice port=8000,disable-ticketing -vga qxl -rtc base=utc,clock=host,driftfix=slew -M rhel6.3.0 -boot order=cdn,once=d,menu=off    -no-kvm-pit-reinjection -no-shutdown --append 'ks=cdrom nicdelay=60 console=ttyS0,115200 console=tty0' -enable-kvm
Comment 1 Golita Yue 2012-03-22 07:38:17 EDT
Created attachment 571971 [details]
qemu-img error info
Comment 2 Golita Yue 2012-03-22 07:47:34 EDT
Because core file is truncated, have not bt info.
If I can reproduce it, will paste the bt info.
Comment 6 Kevin Wolf 2012-04-12 06:29:01 EDT
The reporter saw this only once, so it's hard to tell whether it's really the same, but the symptoms looks very much like bug 798857, so I'm closing this as a duplicate.

*** This bug has been marked as a duplicate of bug 798857 ***

Note You need to log in before you can comment on or make changes to this bug.