Bug 805902 - Scrollwheels on tablets are broken
Scrollwheels on tablets are broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F17Blocker/F17FinalBlocker F17Beta-accepted/F17BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-03-22 08:15 EDT by Hans de Goede
Modified: 2012-03-29 00:13 EDT (History)
3 users (show)

See Also:
Fixed In Version: xorg-x11-drv-evdev-2.7.0-2.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-29 00:13:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2012-03-22 08:15:15 EDT
This is easiest to reproduce by starting a vm with a qemu usb tablet (which has an emulated scrollwheel), start a fully up2date Fedora-17, login and start xev. Then use the mouse wheel of your mouse, notice
that no events are reported. This happens both with the usb tablet, as well as with the uinput tablet generated by the spice-vdagent.

I've run evdev-dump on the spice-vdagent /dev/input/event# node and it is getting the scrollwheel events just fine, therefor I believe this is a xorg-x11-drv-evdev issue.

Since this is something one would expect to work out of the box I'm proposing this as a Fedora 17 blocker,
and as a Fedora 17 beta NTH.
Comment 1 Petr Schindler 2012-03-22 10:27:55 EDT
I vote -1 for blocker. System is usable and this problem occurs mostly on virtual machines. Anyway, comfort is lesser, so it would be really nice if it worked. I'm +1 on NTH (probably final).
Comment 2 Adam Williamson 2012-03-22 14:59:43 EDT
yeah, -1 blocker on this, it doesn't meet any criteria. it is damn annoying, but poking evdev late always gives me the wibblies, so I'm not sure about nth. i'd really like it fixed though!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Adam Williamson 2012-03-22 15:15:35 EDT
Hans, you actually proposed it as Beta blocker not Beta NTH - adjusting. Sorry if the process was hard to understand.
Comment 4 Fedora Update System 2012-03-26 23:14:03 EDT
xorg-x11-drv-evdev-2.7.0-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-drv-evdev-2.7.0-2.fc17
Comment 5 Petr Schindler 2012-03-27 01:34:09 EDT
It works for me with this update.
Comment 6 Adam Williamson 2012-03-28 20:13:26 EDT
Discussed at 2012-03-28 go/no-go meeting, acting as an NTH review meeting. Accepted as NTH: this is a bit borderline as it's not a terribly critical bug and evdev is a fairly sensitive component, but it got accepted, probably because lots of us use VMs all the time and found this very annoying. If we didn't fix it, wheel scrolling would be broken in 17 Beta KVM live boots forever.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Fedora Update System 2012-03-29 00:13:37 EDT
xorg-x11-drv-evdev-2.7.0-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.