Bug 805947 - systemd kills dnsmasq if you stop openstack-nova-network
systemd kills dnsmasq if you stop openstack-nova-network
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openstack-nova (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mark McLoughlin
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-22 10:21 EDT by Mark McLoughlin
Modified: 2012-04-11 23:00 EDT (History)
11 users (show)

See Also:
Fixed In Version: openstack-nova-2012.1-0.10.rc1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-07 23:34:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2012-03-22 10:21:39 EDT
See bug #805942 for a description of a similar bug with libvirt.

The restart issue doesn't apply to nova, since I nova will start dnsmasq again on startup.

So, KillMode=process might be enough for us, but I do worry about whether that means we might leak other processes that we'd prefer not to leak.

This is important, because the theory with upgrades is that you should be able to should down all the services for a period while leaving the instances running. If we kill dnsmasq, however, that means that instances will lose network connectivity when they try to renew their lease (after 2 minutes by default).
Comment 1 Fedora Update System 2012-03-26 05:11:50 EDT
openstack-nova-2011.3.1-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/openstack-nova-2011.3.1-6.fc16
Comment 2 Fedora Update System 2012-03-26 05:15:17 EDT
openstack-nova-2012.1-0.9.rc1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/openstack-nova-2012.1-0.9.rc1.fc17
Comment 3 Fedora Update System 2012-03-28 01:56:38 EDT
Package openstack-nova-2012.1-0.9.rc1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openstack-nova-2012.1-0.9.rc1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4798/openstack-nova-2012.1-0.9.rc1.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-03-29 15:01:14 EDT
openstack-nova-2012.1-0.10.rc1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/openstack-nova-2012.1-0.10.rc1.fc17
Comment 5 Fedora Update System 2012-03-29 21:29:53 EDT
openstack-nova-2011.3.1-7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/openstack-nova-2011.3.1-7.fc16
Comment 6 Fedora Update System 2012-04-07 23:34:47 EDT
openstack-nova-2011.3.1-7.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2012-04-11 23:00:34 EDT
openstack-nova-2012.1-0.10.rc1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.