Bug 805978 - Error importing repomd.xml from fedora: Unable to open /mnt/sysimage/var/cache/yum/ppc64/20120321/fedora/repomd.xml
Error importing repomd.xml from fedora: Unable to open /mnt/sysimage/var/cach...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
ppc64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F17Alphappc
  Show dependency treegraph
 
Reported: 2012-03-22 11:51 EDT by Mark Hamzy
Modified: 2013-07-04 09:01 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-23 10:15:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (6.82 KB, text/x-log)
2012-03-22 11:51 EDT, Mark Hamzy
no flags Details
program.log (53.33 KB, text/x-log)
2012-03-22 11:52 EDT, Mark Hamzy
no flags Details
storage.log (145.60 KB, text/x-log)
2012-03-22 11:52 EDT, Mark Hamzy
no flags Details
syslog (184.04 KB, application/octet-stream)
2012-03-22 11:53 EDT, Mark Hamzy
no flags Details
yum.log (1.11 KB, text/x-log)
2012-03-22 11:53 EDT, Mark Hamzy
no flags Details

  None (edit)
Description Mark Hamzy 2012-03-22 11:51:45 EDT
Created attachment 572022 [details]
anaconda.log

Description of problem:

During installation, I see the following error:

Error importing repomd.xml from fedora: Unable to open /mnt/sysimage/var/cache/yum/ppc64/20120321/fedora/repomd.xml

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mark Hamzy 2012-03-22 11:52:27 EDT
Created attachment 572023 [details]
program.log
Comment 2 Mark Hamzy 2012-03-22 11:52:48 EDT
Created attachment 572024 [details]
storage.log
Comment 3 Mark Hamzy 2012-03-22 11:53:12 EDT
Created attachment 572025 [details]
syslog
Comment 4 Mark Hamzy 2012-03-22 11:53:30 EDT
Created attachment 572026 [details]
yum.log
Comment 5 David Cantrell 2012-03-22 11:55:41 EDT
mgracik,

This looks like something you've dealt with in lorax recently.  Can you have a look at this and see what's up?
Comment 6 Mark Hamzy 2012-03-22 16:08:33 EDT
[anaconda root@9-5-90-148 /]# cat /tmp/anaconda-yum.conf

[main]
installroot=/mnt/sysimage
cachedir=/var/cache/yum/$basearch/$releasever
keepcache=0
logfile=/tmp/yum.log
metadata_expire=0
obsoletes=True
pluginpath=/usr/lib/yum-plugins,/tmp/updates/yum-plugins
pluginconfpath=/etc/yum/pluginconf.d,/tmp/updates/pluginconf.d
plugins=1
reposdir=/etc/anaconda.repos.d,/tmp/updates/anaconda.repos.d,/tmp/product/anaconda.repos.d
[anaconda root@9-5-90-148 /]# ls /etc/anaconda.repos.d/
fedora-updates-testing.repo  fedora-updates.repo  fedora.repo
[anaconda root@9-5-90-148 /]# ls /etc/anaconda.repos.d/fedora.repo
/etc/anaconda.repos.d/fedora.repo
[anaconda root@9-5-90-148 /]# cat /etc/anaconda.repos.d/fedora.repo
[fedora]
name=Fedora $releasever - $basearch
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=$basearch
enabled=1
#metadata_expire=7d
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

[fedora-debuginfo]
name=Fedora $releasever - $basearch - Debug
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/$basearch/debug/
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=fedora-debug-$releasever&arch=$basearch
enabled=0
metadata_expire=7d
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

[fedora-source]
name=Fedora $releasever - Source
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/source/SRPMS/
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=fedora-source-$releasever&arch=$basearch
enabled=0
metadata_expire=7d
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch
Comment 7 Martin Gracik 2012-03-23 08:52:11 EDT
So I talked to Mark and it looks like the compose was done with missing parameters to pungi.

Adding parameters "--ver 17-Beta-LocalTest --flavor Fedora" to pungi fixed it.

Note You need to log in before you can comment on or make changes to this bug.