Bug 806008 - [REST API] healt-check url for application is missing
[REST API] healt-check url for application is missing
Status: CLOSED DUPLICATE of bug 805989
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Krishna Raman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-22 12:41 EDT by Andre Dietisheim
Modified: 2015-05-14 21:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-23 05:35:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Dietisheim 2012-03-22 12:41:35 EDT
In the legacy service, one would get a health-check url. This url is the url at which the client library may wait for the application to become reachable (all internal setups were successfull, the app is ready). The typical setup (when using the legacy service) was:

1) request app creation
2) poll the healt-url until it reports 200 OK (and "1" in the response body).

We need the beforementioned attribute at which the readyness-service may be queried or an alternative approach. I guess that it would be ideal to be able to query the application resource and have a state property in the response.
Comment 1 Andre Dietisheim 2012-03-22 14:01:32 EDT
The beforementioned approach to report the application state when GET'ing the application resource is filed in https://bugzilla.redhat.com/show_bug.cgi?id=805989
Comment 2 Andre Dietisheim 2012-03-23 05:35:35 EDT
We suggest that the response to a GET on the application resource would hold a property that reports the application state. This state could report the creation state:

CREATING -> STARTING -> STARTED

I therefore close this issue and add our requirement to https://bugzilla.redhat.com/show_bug.cgi?id=805989

*** This bug has been marked as a duplicate of bug 805989 ***

Note You need to log in before you can comment on or make changes to this bug.