Bug 806027 - Operations with parameters does not work for Drools application
Operations with parameters does not work for Drools application
Status: CLOSED WONTFIX
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- BRMS 5 (Show other bugs)
JON 3.0.0
i686 Linux
unspecified Severity urgent
: ---
: JON 3.2.0
Assigned To: John Graham
Mike Foley
:
Depends On: 886537
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-22 13:27 EDT by Pavel Kralik
Modified: 2013-04-30 19:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-04 18:00:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Kralik 2012-03-22 13:27:59 EDT
Description of problem:

When monitoring the Drools example application, the Operations with parameters for the Drools app session rise an IllegalStateException. The same application monitored by JConsole executes Operations with parameter without problem.

Version-Release number of selected component (if applicable):

BRMS-5.2.0.GA
JON 3.0.1.GA-7

How reproducible:

Always

Steps to Reproduce:
1. Install the JON 3.0.1 server and with BRMS plugin

2. Run a drools-jon-example application

https://svn.devel.redhat.com/repos/jboss-qa/guvnor/branches/BRMS-5.2.x/drools-jon-example/

with ant compile; ant server
     ant client.phase1; ant client.phase2

3. Discover the JMXServer and go to JMXServer > Drools Services ... > KSession {sessionId} to the Operations tab and execute eg Get statistics for rule with "hello world" parameter.
  
https://svn.devel.redhat.com/repos/jboss-qa/guvnor/branches/BRMS-5.2.x/drools-jon-example/
   with ant compile; ant server
   ant client.phase1; ant
client.phase2

Actual results:

java.lang.IllegalStateException: Name [ruleName] specified for parameter of operation [getStatsForRule] on MBean [org.drools.kbases:type=my-own-knowledge-base,group=Sessions,sessionId=Session-1] is invalid. The MBean operation does not take a parameter by that name.
	at org.rhq.plugins.jmx.MBeanResourceComponent.invokeOperation(MBeanResourceComponent.java:576)
	at org.rhq.plugins.jmx.MBeanResourceComponent.invokeOperation(MBeanResourceComponent.java:524)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocationThread.call(ResourceContainer.java:552)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:636)


Expected results:

The Operations with parameter should return:
activationsCreated=1 activationsCancelled=0 activationsFired=1 firingTime=0ms

Additional info:
N/A
Comment 2 mark yarborough 2012-09-24 15:23:04 EDT
Pavel: Please open a Drools/BRMS bug for the actual fix and then link the two bugs together. If this is not clear, please ping myarboro and we'll provide more background. Thanks!
Comment 3 Pavel Kralik 2012-12-12 09:03:22 EST
Opended Drools/BRMS BZ:

https://bugzilla.redhat.com/show_bug.cgi?id=886537
Comment 4 mark yarborough 2013-03-04 18:00:48 EST
Closed since has been opened in the appropriate product, BRMS, in https://bugzilla.redhat.com/show_bug.cgi?id=886537

Note You need to log in before you can comment on or make changes to this bug.