Bug 806035 - yum update conflict between clang and gcc-c++
yum update conflict between clang and gcc-c++
Status: CLOSED DUPLICATE of bug 802080
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-22 13:51 EDT by Carlo Teubner
Modified: 2012-03-26 04:46 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-26 04:46:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlo Teubner 2012-03-22 13:51:29 EDT
# yum update 
Loaded plugins: auto-update-debuginfo, presto, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package cpp.x86_64 0:4.6.2-1.fc16 will be updated
---> Package cpp.x86_64 0:4.6.3-2.fc16 will be an update
---> Package gcc.x86_64 0:4.6.2-1.fc16 will be updated
---> Package gcc.x86_64 0:4.6.3-2.fc16 will be an update
---> Package gcc-c++.x86_64 0:4.6.2-1.fc16 will be updated
--> Processing Dependency: gcc-c++ = 4.6.2 for package: clang-2.9-6.fc16.x86_64
---> Package gcc-c++.x86_64 0:4.6.3-2.fc16 will be an update
---> Package gcc-gfortran.x86_64 0:4.6.2-1.fc16 will be updated
---> Package gcc-gfortran.x86_64 0:4.6.3-2.fc16 will be an update
---> Package libgcj.x86_64 0:4.6.2-1.fc16 will be updated
---> Package libgcj.x86_64 0:4.6.3-2.fc16 will be an update
---> Package libgfortran.x86_64 0:4.6.2-1.fc16 will be updated
---> Package libgfortran.x86_64 0:4.6.3-2.fc16 will be an update
---> Package libgomp.x86_64 0:4.6.2-1.fc16 will be updated
---> Package libgomp.x86_64 0:4.6.3-2.fc16 will be an update
---> Package libquadmath.x86_64 0:4.6.2-1.fc16 will be updated
---> Package libquadmath.x86_64 0:4.6.3-2.fc16 will be an update
---> Package libquadmath-devel.x86_64 0:4.6.2-1.fc16 will be updated
---> Package libquadmath-devel.x86_64 0:4.6.3-2.fc16 will be an update
---> Package libstdc++.x86_64 0:4.6.2-1.fc16 will be updated
---> Package libstdc++.x86_64 0:4.6.3-2.fc16 will be an update
---> Package libstdc++-devel.x86_64 0:4.6.2-1.fc16 will be updated
---> Package libstdc++-devel.x86_64 0:4.6.3-2.fc16 will be an update
---> Package libtool.x86_64 0:2.4-8.fc16 will be updated
---> Package libtool.x86_64 0:2.4-9.fc16 will be an update
---> Package libtool-ltdl.x86_64 0:2.4-8.fc16 will be updated
---> Package libtool-ltdl.x86_64 0:2.4-9.fc16 will be an update
--> Finished Dependency Resolution
Error: Package: clang-2.9-6.fc16.x86_64 (@updates)
           Requires: gcc-c++ = 4.6.2
           Removing: gcc-c++-4.6.2-1.fc16.x86_64 (@anaconda-0)
               gcc-c++ = 4.6.2-1.fc16
           Updated By: gcc-c++-4.6.3-2.fc16.x86_64 (updates)
               gcc-c++ = 4.6.3-2.fc16
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


The suggestion to run "yum update --skip-broken" does not work; it yields:
<snip>
--> Processing Dependency: gcc = 4.6.2-1.fc16 for package: gcc-c++-4.6.2-1.fc16.x86_64
---> Package libstdc++.i686 0:4.6.2-1.fc16 will be installed
<snip>
Error: Protected multilib versions: libstdc++-4.6.2-1.fc16.i686 != libstdc++-4.6.3-2.fc16.x86_64
Comment 1 Marek Zdunek 2012-03-22 14:16:00 EDT
error message:
Błąd: Pakiet: clang-2.9-6.fc16.x86_64 (@updates)
          Wymaga: gcc-c++ = 4.6.2
          Usuwanie: gcc-c++-4.6.2-1.fc16.x86_64 (@anaconda-0)
              gcc-c++ = 4.6.2-1.fc16
          Zaktualizowano przez: gcc-c++-4.6.3-2.fc16.x86_64 (updates)
              gcc-c++ = 4.6.3-2.fc16

skipped packages:
Pakiety pominięto z powodu problemów z zależnościami:
    cpp-4.6.3-2.fc16.x86_64 z updates
    gcc-4.6.3-2.fc16.x86_64 z updates
    gcc-c++-4.6.3-2.fc16.x86_64 z updates
    gcc-gfortran-4.6.3-2.fc16.x86_64 z updates
    libgomp-4.6.3-2.fc16.i686 z updates
    libgomp-4.6.3-2.fc16.x86_64 z updates
    libquadmath-devel-4.6.3-2.fc16.x86_64 z updates
    libstdc++-4.6.3-2.fc16.i686 z updates
    libstdc++-4.6.3-2.fc16.x86_64 z updates
    libstdc++-devel-4.6.2-1.fc16.i686 z fedora
    libstdc++-devel-4.6.3-2.fc16.x86_64 z updates
    libtool-2.4-9.fc16.x86_64 z updates

and:
Błąd: Chronione wersje multilib: libgfortran-4.6.3-2.fc16.x86_64 != libgfortran-4.6.2-1.fc16.i686
Błąd: Chronione wersje multilib: libquadmath-4.6.2-1.fc16.i686 != libquadmath-4.6.3-2.fc16.x86_64
Comment 2 hhlp 2012-03-23 17:29:19 EDT
sudo yum update
 
Complementos cargados:aliases, fastestmirror, langpacks, presto, refresh-
                    : packagekit, remove-with-leaves
Loading mirror speeds from cached hostfile
 * fedora: fedora.mirrors.ovh.net
 * rpmfusion-free: mirror.switch.ch
 * rpmfusion-free-updates: mirror.switch.ch
 * rpmfusion-nonfree: mirror.switch.ch
 * rpmfusion-nonfree-updates: mirror.switch.ch
 * updates: fedora.mirrors.ovh.net
Configurando el proceso de actualización
Resolviendo dependencias
--> Ejecutando prueba de transacción
---> Paquete cpp.x86_64 0:4.6.2-1.fc16 debe ser actualizado
---> Paquete cpp.x86_64 0:4.6.3-2.fc16 debe ser una actualización
---> Paquete gcc.x86_64 0:4.6.2-1.fc16 debe ser actualizado
---> Paquete gcc.x86_64 0:4.6.3-2.fc16 debe ser una actualización
---> Paquete gcc-c++.x86_64 0:4.6.2-1.fc16 debe ser actualizado
--> Procesando dependencias: gcc-c++ = 4.6.2 para el paquete: clang-2.9-6.fc16.x86_64
---> Paquete gcc-c++.x86_64 0:4.6.3-2.fc16 debe ser una actualización
---> Paquete libgcc.i686 0:4.6.2-1.fc16 debe ser actualizado
---> Paquete libgcc.x86_64 0:4.6.2-1.fc16 debe ser actualizado
---> Paquete libgcc.i686 0:4.6.3-2.fc16 debe ser una actualización
---> Paquete libgcc.x86_64 0:4.6.3-2.fc16 debe ser una actualización
---> Paquete libgfortran.x86_64 0:4.6.2-1.fc16 debe ser actualizado
---> Paquete libgfortran.x86_64 0:4.6.3-2.fc16 debe ser una actualización
---> Paquete libgomp.x86_64 0:4.6.2-1.fc16 debe ser actualizado
---> Paquete libgomp.x86_64 0:4.6.3-2.fc16 debe ser una actualización
---> Paquete libquadmath.x86_64 0:4.6.2-1.fc16 debe ser actualizado
---> Paquete libquadmath.x86_64 0:4.6.3-2.fc16 debe ser una actualización
---> Paquete libstdc++.i686 0:4.6.2-1.fc16 debe ser actualizado
---> Paquete libstdc++.x86_64 0:4.6.2-1.fc16 debe ser actualizado
---> Paquete libstdc++.i686 0:4.6.3-2.fc16 debe ser una actualización
---> Paquete libstdc++.x86_64 0:4.6.3-2.fc16 debe ser una actualización
---> Paquete libstdc++-devel.x86_64 0:4.6.2-1.fc16 debe ser actualizado
---> Paquete libstdc++-devel.x86_64 0:4.6.3-2.fc16 debe ser una actualización
---> Paquete libtool.x86_64 0:2.4-8.fc16 debe ser actualizado
---> Paquete libtool.x86_64 0:2.4-9.fc16 debe ser una actualización
---> Paquete libtool-ltdl.i686 0:2.4-8.fc16 debe ser actualizado
---> Paquete libtool-ltdl.x86_64 0:2.4-8.fc16 debe ser actualizado
---> Paquete libtool-ltdl.i686 0:2.4-9.fc16 debe ser una actualización
---> Paquete libtool-ltdl.x86_64 0:2.4-9.fc16 debe ser una actualización
--> Resolución de dependencias finalizada
Error: Paquete: clang-2.9-6.fc16.x86_64 (@updates)
           Necesita: gcc-c++ = 4.6.2
           Eliminando: gcc-c++-4.6.2-1.fc16.x86_64 (@fedora)
               gcc-c++ = 4.6.2-1.fc16
           Actualizado por: gcc-c++-4.6.3-2.fc16.x86_64 (updates)
               gcc-c++ = 4.6.3-2.fc16
 Podría intentar utilizar el comando --skip-broken para sortear el problema
Podría intentar ejecutar: rpm- Va --nofiles --nodigest
Comment 3 timko.charles 2012-03-24 13:04:50 EDT
---> Package selinux-policy.noarch 0:3.10.0-75.fc16 will be updated
---> Package selinux-policy.noarch 0:3.10.0-80.fc16 will be an update
---> Package selinux-policy-targeted.noarch 0:3.10.0-75.fc16 will be updated
---> Package selinux-policy-targeted.noarch 0:3.10.0-80.fc16 will be an update
---> Package xorg-x11-server-Xephyr.x86_64 0:1.11.4-1.fc16 will be updated
---> Package xorg-x11-server-Xephyr.x86_64 0:1.11.4-2.fc16 will be an update
---> Package xorg-x11-server-Xorg.x86_64 0:1.11.4-1.fc16 will be updated
---> Package xorg-x11-server-Xorg.x86_64 0:1.11.4-2.fc16 will be an update
---> Package xorg-x11-server-common.x86_64 0:1.11.4-1.fc16 will be updated
---> Package xorg-x11-server-common.x86_64 0:1.11.4-2.fc16 will be an update
--> Finished Dependency Resolution

Packages skipped because of dependency problems:
    cpp-4.6.3-2.fc16.x86_64 from updates
    gcc-4.6.3-2.fc16.x86_64 from updates
    gcc-c++-4.6.3-2.fc16.x86_64 from updates
    libtool-2.4-9.fc16.x86_64 from updates
Error: Protected multilib versions: libstdc++-devel-4.6.3-2.fc16.x86_64 != libstdc++-devel-4.6.2-1.fc16.i686
Error: Protected multilib versions: libstdc++-4.6.3-2.fc16.x86_64 != libstdc++-4.6.2-1.fc16.i686
Error: Protected multilib versions: libgomp-4.6.3-2.fc16.x86_64 != libgomp-4.6.2-1.fc16.i686


Same here...  Any idea what is causing this?
Comment 4 Michel Alexandre Salim 2012-03-26 04:46:10 EDT

*** This bug has been marked as a duplicate of bug 802080 ***

Note You need to log in before you can comment on or make changes to this bug.