Bug 806086 - Current hard-dependency on cron* makes cron un-installable by default
Current hard-dependency on cron* makes cron un-installable by default
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: man-db (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Schiffer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-22 16:51 EDT by abrouwers
Modified: 2012-05-02 00:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: man-db-2.6.0.2-5.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-02 00:38:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description abrouwers 2012-03-22 16:51:33 EDT
Description of problem:

Presently, man-db has a hard-dependency on cron.  It seems as though this is used to periodically update the manpage database.  Unfortunately, as someone who really doesn't need cron for anything, this also forces cron to remain installed on the system, whether or not the user requires it.

Is it possible that this dependency could be eliminated ?  man-db is used on other distros without forcing the update only through cron (and instead, at package install time, updating, etc); I haven't quite investigated how this is handled in fedora, but it seems that I can at least immediately view man pages for recently installed packages, so surely a post-install hook is taking care of things generally with package transactions.

Is it possible to eliminate this as a hard-dep for man-db?  I understand alternatives exist for having cron not run (by masking the service via. systemd), but it seems rather weird by default that man-db is the only thing forcing cron to remain on the system for a fresh installation.
Comment 1 Peter Schiffer 2012-03-29 08:18:39 EDT
Hello,

thanks for your report. I understand what you mean. I am suggesting to remove hard-dependency on cron, but keep the cron.daily file, so the database can be updated if the cron is installed. Also, update the man DB after installation or update of the man-db package.

The man DB is not necessary for viewing man pages, so I don't think this should be a problem.

What do you think?


Thanks,

peter
Comment 2 abrouwers 2012-03-29 10:09:41 EDT
Hi Peter,

Thanks for the response!  I actually didn't know that the db didn't need to be updated regularly for proper man page viewing.  Installing the cron file definitely seems harmless, as most people will probably be running cron still.

It seems like installing cron by default is definitely desirable still, but should be opt-out-able for the user.  Since systemd has added the journal, things like the syslogger+logrotate seem relatively unimportant to some people, so the requirement of cron for those may be decreasing.  The ability to uninstall would be great, as opposed to managing masking the services for such cases.

Thanks again.
Comment 3 abrouwers 2012-03-30 09:22:41 EDT
It looks like this will also allow the user to remove rsyslog cleanly, which had had a similar rsyslog -> logrotate -> cron -> man-db  chain that made it tough to purge from a system.  As a happy systemd-journald user who doesn't really need a full-blown system logger any more, this is great!  Thanks again for taking the time to check this out.
Comment 4 Peter Schiffer 2012-04-05 10:45:20 EDT
Fixed in:
man-db-2.6.1-1.fc18
http://koji.fedoraproject.org/koji/buildinfo?buildID=311838
Comment 5 abrouwers 2012-04-05 11:48:00 EDT
Hi Peter,

Great, thanks!  Any plans to build an F17 package too?  Might be nice to have rsyslog and such removable by the user, especially after systemd has gained journald.

Cheers,
Andrew
Comment 6 Peter Schiffer 2012-04-05 11:58:52 EDT
Hi Andrew,

I'll build an F17 package too, don't worry ;-)
I am just checking other bugs for the man-db I can fix in F17..

peter
Comment 7 abrouwers 2012-04-20 11:29:07 EDT
I've tested this for a couple weeks too, and it seems to not have any negative impact that I can tell.  Would be great to sneak it in before F17 final :-)  Thanks again for taking the time to consider removing this dependency!
Comment 8 Fedora Update System 2012-04-25 14:01:06 EDT
man-db-2.6.0.2-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/man-db-2.6.0.2-5.fc17
Comment 9 Fedora Update System 2012-04-26 15:28:26 EDT
Package man-db-2.6.0.2-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing man-db-2.6.0.2-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6672/man-db-2.6.0.2-5.fc17
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-05-02 00:38:15 EDT
man-db-2.6.0.2-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.