Bug 806098 - Support qemu 1.0
Support qemu 1.0
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.2
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Libvirt Maintainers
Virtualization Bugs
: TestOnly
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-22 17:19 EDT by Orion Poplawski
Modified: 2012-03-26 16:21 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-26 05:34:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2012-03-22 17:19:13 EDT
Description of problem:

libvirt-0.9.4-23.el6_2.6.x86_64 cannot parse the qemu 1.0 version strings:

15:11:04.081: 7168: error : qemuCapsParseHelpStr:1168 : internal error cannot parse /usr/bin/qemu-system-arm version number in 'QEMU emulator version 1.0 (qemu-kvm-1.0), Copyright (c) 2003-2008 Fabrice Bellard'
Comment 2 Peter Krempa 2012-03-23 04:12:32 EDT
Already supported upstream (0.9.8) and backported with the rebase into 6.3:

commit dd8e8956060f38b084d581ed63f934c3d8202071
Author: Jiri Denemark <jdenemar@redhat.com>
Date:   Fri Dec 2 21:20:15 2011 +0100

    Add support for QEMU 1.0
Comment 3 Alex Jia 2012-03-25 03:26:03 EDT
(In reply to comment #2)
> Already supported upstream (0.9.8) and backported with the rebase into 6.3:
> 
> commit dd8e8956060f38b084d581ed63f934c3d8202071
> Author: Jiri Denemark <jdenemar@redhat.com>
> Date:   Fri Dec 2 21:20:15 2011 +0100
> 
>     Add support for QEMU 1.0

Hello Peter, Jiri,
I know qemu version is 1.0, but I want to confirm which version qemu-kvm and libvirt are? the current bug is ON_QA status, however, I can't find any libvirt version on 'Fixed In Version:' field.

Thanks,
Alex
Comment 4 Dave Allan 2012-03-25 21:59:14 EDT
Hey Alex,

This was fixed prior to the rebase, so any recent libvirt version will have support for it.  You'd also need a non-RHEL qemu to test.  

Dave
Comment 6 Daniel Berrange 2012-03-26 05:34:22 EDT
Marking this CLOSED->UPSTREAM, since this is fixed upstream & RHEL does not support running custom built QEMU binaries.
Comment 7 Dave Allan 2012-03-26 16:21:16 EDT
Fair enough

Note You need to log in before you can comment on or make changes to this bug.