Bug 806130 - status command explodes
status command explodes
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-22 21:31 EDT by Joshua Wulf
Modified: 2014-10-19 19:00 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.22.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 21:31:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-03-22 21:31:22 EDT
[jwulf@dhcp-1-77 Red_Hat_Engineers_Guide_to_Zanata]$ csprocessor status
CSProcessor client version: 0.22.3
Loading configuration from /home/jwulf/.config/csprocessor.ini
Connecting to Skynet server: http://skynet.usersys.redhat.com:8080/TopicIndex

Exception in thread "main" java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.eclipse.jdt.internal.jarinjarloader.JarRsrcLoader.main(JarRsrcLoader.java:58)
Caused by: java.util.regex.PatternSyntaxException: Look-behind group does not have an obvious maximum length near index 40
CHECKSUM[ ]*=[ ]*(?<Checksum>[A-Za-z0-9]+)
                                        ^
	at java.util.regex.Pattern.error(Pattern.java:1730)
	at java.util.regex.Pattern.group0(Pattern.java:2505)
	at java.util.regex.Pattern.sequence(Pattern.java:1823)
	at java.util.regex.Pattern.expr(Pattern.java:1769)
	at java.util.regex.Pattern.compile(Pattern.java:1477)
	at java.util.regex.Pattern.<init>(Pattern.java:1150)
	at java.util.regex.Pattern.compile(Pattern.java:840)
	at com.redhat.contentspec.client.commands.StatusCommand.process(StatusCommand.java:126)
	at com.redhat.contentspec.client.Client.processArgs(Client.java:195)
	at com.redhat.contentspec.client.Client.main(Client.java:85)
	... 5 more
Comment 1 Lee Newson 2012-03-22 22:16:42 EDT
Fixed in 0.22.4

Cause:
Trying to use Java SE 7 Named Capture Groups

Consequence:
An error occurred when trying to create the Regex Expression that stopped the command from working when using Java SE 6.

Fix:
Changed the command to use NamedPattern and NamedMatcher which are from a custom library that enables the use of Named Capture Groups in Java SE 5 & 6. See:http://code.google.com/p/named-regexp/ (Note: The library with the processor is modified to fix the bugs from that library)
Comment 2 Lee Newson 2013-06-06 21:31:40 EDT
Closing and setting as current release as no QA was performed by the original reporter. If there is still an issue with this bug still than please re-open it.

Note You need to log in before you can comment on or make changes to this bug.