Bug 806210 - perf hang during report data collected by "perf kvm --guest "
perf hang during report data collected by "perf kvm --guest "
Status: CLOSED DUPLICATE of bug 846702
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Jiri Olsa
Guangze Bai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-23 04:17 EDT by Xiaoqing Wei
Modified: 2016-02-10 08:14 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-29 07:04:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaoqing Wei 2012-03-23 04:17:44 EDT
Description of problem:
perf hang during report data collected by   "perf kvm --guest record -p $qemu_pid"

Version-Release number of selected component (if applicable):
perf-2.6.32-251.el6.x86_64
kernel-2.6.32-251.el6.x86_64
How reproducible:
100%

Steps to Reproduce:
1. boot a qemu-kvm guest
2. get the qemu_pid by "ps -C qemu-kvm"
3. perf kvm --guest record -p $qemu_pid
4. ctrl+c to finish the collecting
5. perf report -i perf.data.guest  ## that file generated by perf record
  
Actual results:
perf hangs, ctrl+c unable to end the process, can be killed by "kill $perf_pid"

Expected results:
perf report works well, not hang.

Additional info:

perf report -i perf.data.host ## works well
## where the file generated by "perf kvm --host record -p qemu_pid"




Host info:
processor	: 3
vendor_id	: GenuineIntel
cpu family	: 6
model		: 15
model name	: Intel(R) Xeon(R) CPU            5130  @ 2.00GHz


cmd to boot guest:

qemu-kvm -S -monitor stdio -chardev socket,id=serial_id_20120322-155424-HidE,path=/tmp/serial-20120322-155424-HidE,server,nowait -device isa-serial,chardev=serial_id_20120322-155424-HidE -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=0x4 -drive file=/home/cpu_host.qcow2,index=0,if=none,id=drive-virtio-disk1,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk1,id=virtio-disk1 -device virtio-net-pci,netdev=idCcvK9c,mac=9a:20:d9:0d:c9:0a,id=ndev00idCcvK9c,bus=pci.0,addr=0x3 -netdev tap,id=idCcvK9c,vhost=on -m 4G -smp 4,cores=2,threads=1,sockets=2 -device usb-tablet,id=usb-tablet1,bus=usb1.0 -spice port=8010,disable-ticketing -vga qxl -rtc base=utc,clock=host,driftfix=slew -M rhel6.3.0 -boot order=cdn,once=c,menu=off -no-kvm-pit-reinjection -enable-kvm -cpu host


gdb -p perf_pid   ## during perf hangs
#0  0x00000036d8ae40fa in mmap64 () at ../sysdeps/unix/syscall-template.S:82
#1  0x0000000000454f4a in __perf_session__process_events (session=0x2a35890, 
    data_offset=<value optimized out>, data_size=<value optimized out>, file_size=312, tool=
    0x7fff65a6bc80) at util/session.c:1108
#2  0x000000000041a19c in __cmd_report (argc=0, argv=<value optimized out>, 
    prefix=<value optimized out>) at builtin-report.c:281
#3  cmd_report (argc=0, argv=<value optimized out>, prefix=<value optimized out>)
    at builtin-report.c:599
#4  0x000000000040ef33 in run_builtin (p=0x6a6288, argc=3, argv=0x7fff65a6c170) at perf.c:273
#5  0x000000000040fa4b in handle_internal_command (argc=3, argv=0x7fff65a6c170) at perf.c:344
#6  run_argv (argc=3, argv=0x7fff65a6c170) at perf.c:388
#7  main (argc=3, argv=0x7fff65a6c170) at perf.c:486
Comment 1 Xiaoqing Wei 2012-03-23 04:19:32 EDT
dmesg shows:

perf[5006]: segfault at 40 ip 000000000045617d sp 00007fff03fda020 error 4 in perf[400000+a5000]
Comment 3 RHEL Product and Program Management 2012-05-04 00:04:13 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 4 Jiri Olsa 2012-08-29 07:04:30 EDT
fixed by BZ  846702 - perf tool 3.5 sync

*** This bug has been marked as a duplicate of bug 846702 ***

Note You need to log in before you can comment on or make changes to this bug.