Bug 806214 - deploy.xml fails when uploaded as recipe
deploy.xml fails when uploaded as recipe
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Provisioning (Show other bugs)
JON 3.0.0
Unspecified Unspecified
high Severity unspecified
: ---
: JON 3.1.0
Assigned To: John Mazzitelli
Mike Foley
:
Depends On: 615978
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-23 04:33 EDT by bkramer
Modified: 2013-09-11 07:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-11 07:02:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
deploy.xml file that can be used to reproduce the issue - just change the value of rhq:url-file (2.69 KB, text/xml)
2012-03-23 04:33 EDT, bkramer
no flags Details

  None (edit)
Description bkramer 2012-03-23 04:33:10 EDT
Created attachment 572192 [details]
deploy.xml file that can be used to reproduce the issue - just change the value of rhq:url-file

Description of problem:
The attached deploy.xml fails when uploaded as a recipe. The deployment fails with the following exception:

[] <rhq:bundle> rhq.deploy.dir="/home/JBoss/jboss-eap-5.1.2/jboss-as/server/default"
[] <rhq:bundle> rhq.deploy.id="10211"
[] <rhq:bundle> Executing 'upgrade' phase for deployment with id [10211] from bundle 'jboss-as-helloworld' version 1.0.5 using config Configuration[id=0, properties[], rawConfigurations[]] [dryRun=false, revert=false, clean=false]...
RHQ_AUDIT_MESSAGE___SUCCESS___Pre-Install Started___The pre install target will start___The pre install target named [preinstall] will start___
RHQ_AUDIT_MESSAGE___FAILURE___Pre-Install Failure___The pre install target does not exist___The pre install target specified in the recipe [preinstall] does not exist.___
RHQ_AUDIT_MESSAGE___FAILURE___Error Occurred___The deployment could not complete successfully.___org.apache.tools.ant.BuildException:Specified preinstall target (preinstall) does not exist.___Specified preinstall target (preinstall) does not exist.
        at org.rhq.bundle.ant.type.DeploymentUnitType.install(DeploymentUnitType.java:128)
        at org.rhq.bundle.ant.type.DeploymentUnitType.upgrade(DeploymentUnitType.java:377)
        at org.rhq.bundle.ant.task.BundleTask.execute(BundleTask.java:157)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
        at org.apache.tools.ant.Task.perform(Task.java:348)
        at org.apache.tools.ant.Target.execute(Target.java:390)
        at org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:179)
        at org.apache.tools.ant.ProjectHelper.configureProject(ProjectHelper.java:80)
        at org.rhq.bundle.ant.AntLauncher.executeBundleDeployFile(AntLauncher.java:111)
        at org.rhq.plugins.ant.AntBundlePluginComponent.executeDeploymentPhase(AntBundlePluginComponent.java:304)
        at org.rhq.plugins.ant.AntBundlePluginComponent.deployBundle(AntBundlePluginComponent.java:137)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocationThread.call(ResourceContainer.java:552)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
        at java.util.concurrent.FutureTask.run(FutureTask.java:138)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at java.lang.Thread.run(Thread.java:619)
[] <rhq:bundle>



At the same time, when you package the deploy.xml in a zip file and try it again, it works fine. 


Version-Release number of selected component (if applicable):
JON 3.0.0 GA


How reproducible:
Always


Steps to Reproduce:
1. in the deploy.xml file change rhq:url-file to point to the application in the test environment  
2. upload deploy.xml as a recipe and try to deploy the application.

  
Actual results:
Deployment fails with the above exception.

Expected results:
Deployment works fine.


Additional info:
Comment 1 Mike Foley 2012-03-26 11:45:46 EDT
on sprint 11 tracker per bz triage (crouch, mfoley, loleary, asantos)
Comment 2 Charles Crouch 2012-03-26 12:16:12 EDT
See https://bugzilla.redhat.com/show_bug.cgi?id=615978 for what we think is the underlying issue

Assigning this to the rhq-uxd tracker. Lets see if there are tweaks to the workflow that make this entire class of problem go away. I'd much prefer that than a fix which requires intricate smartgwt/gwt configuration and may or may not be browser dependent.


(11:06:09 AM) ccrouch: mazz: can't we just do a normal file upload
(11:06:33 AM) ccrouch: isnt this being caused because we try and display the uploaded file?
(11:08:28 AM) mazz: its because we are using the upload just to hand it back to the browser.
(11:08:47 AM) mazz: letting the user see it before going on to the next step
(11:09:10 AM) mazz: I *think* the xml is corrupted on the way back
(11:09:13 AM) mazz: but I'm not actually sure
(11:09:19 AM) ccrouch: right, so why don't we just not hand it back to the browser
(11:09:38 AM) ccrouch: they should now what the file looks like, they just uploaded it :-)
(11:10:12 AM) mazz: I suppose you could do that. that would change the workflow of the UI - we'd have to refactor how this page works I think
Comment 3 Larry O'Leary 2012-03-27 22:25:20 EDT
See my proposed patch and comments on the upstream bug: https://bugzilla.redhat.com/show_bug.cgi?id=615978#c15
Comment 4 John Mazzitelli 2012-04-11 14:48:24 EDT
(In reply to comment #3)
> See my proposed patch and comments on the upstream bug:
> https://bugzilla.redhat.com/show_bug.cgi?id=615978#c15

that patch and some additional code has been applied to master, see https://bugzilla.redhat.com/show_bug.cgi?id=615978#c22
Comment 5 Charles Crouch 2012-04-16 10:08:53 EDT
Unassociating from the RHQ trackers. This issue has been addressed by the upstream bug #615978
Comment 6 Sunil Kondkar 2012-06-12 08:00:18 EDT
Verified on Version: 3.1.0.GA Build Number: b575169:a53e41e

Changed the rhq:url-file in the attached deploy.xml to point to the application in the test environment and uploaded the deploy.xml as a recipe successfully. Deployed the bundle. No exceptions are observed.

Verified on Firefox 10.0.2 and IE version 9.0.8112.16421.

Note You need to log in before you can comment on or make changes to this bug.