Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 806236 - [abrt] libreoffice-core-3.5.1.2-1.fc17: Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
Summary: [abrt] libreoffice-core-3.5.1.2-1.fc17: Process /usr/lib64/libreoffice/progra...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 17
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:26ec1fbddc8bf45627c05757149...
: 823272 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-23 09:43 UTC by Anton Arapov
Modified: 2014-06-18 08:03 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-29 15:57:12 UTC
Type: ---


Attachments (Terms of Use)
File: dso_list (20.12 KB, text/plain)
2012-03-23 09:43 UTC, Anton Arapov
no flags Details
File: maps (86.27 KB, text/plain)
2012-03-23 09:43 UTC, Anton Arapov
no flags Details
File: backtrace (67.62 KB, text/plain)
2012-03-23 09:43 UTC, Anton Arapov
no flags Details


Links
System ID Private Priority Status Summary Last Updated
FreeDesktop.org 51324 0 None None None Never

Description Anton Arapov 2012-03-23 09:43:09 UTC
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --impress file:///home/anton/Customer%20Portal%20Internal_03202012.odp --splash-pipe=6
crash_function: std::list<Link, std::allocator<Link> >::begin
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.3.0-3.tip0.uprobes.fc17.x86_64
pid:            18424
pwd:            /home/anton
reason:         Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
time:           Fri 23 Mar 2012 09:42:27 CET
uid:            1000
username:       anton

backtrace:      Text file, 69241 bytes
dso_list:       Text file, 20606 bytes
maps:           Text file, 88339 bytes

environ:
:GIT_PS1_SHOWDIRTYSTATE=true
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=bandura.brq.redhat.com
:LC_MONETARY=en_GB.utf8
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GIO_LAUNCHED_DESKTOP_FILE_PID=18410
:GPG_AGENT_INFO=/tmp/keyring-XLyyPc/gpg:0:1
:SHELL=/bin/bash
:TERM=xterm-256color
:DESKTOP_STARTUP_ID=nautilus-18399-bandura.brq.redhat.com-libreoffice-0_TIME6183650
:HISTSIZE=1000
:XDG_SESSION_COOKIE=140f39c967431aadf43a7e3200000010-1332485955.765921-668108218
:GJS_DEBUG_OUTPUT=stderr
:G_MESSAGES_DEBUG=all
:LC_NUMERIC=en_GB.utf8
:OLDPWD=/usr/lib64/libreoffice/program
:QTDIR=/usr/lib64/qt-3.3
:GNOME_KEYRING_CONTROL=/tmp/keyring-XLyyPc
:QTINC=/usr/lib64/qt-3.3/include
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:USER=anton
:SSH_AUTH_SOCK=/tmp/keyring-XLyyPc/ssh
:USERNAME=anton
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1117,unix/unix:/tmp/.ICE-unix/1117
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/libreoffice-impress.desktop
:MAIL=/var/spool/mail/anton
:PATH=/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/anton/.local/bin:/home/anton/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/anton
:XMODIFIERS=@im=none
:EDITOR=vim
:KDE_IS_PRELINKED=1
:GNOME_KEYRING_PID=1109
:LANG=en_GB.utf8
:GDM_LANG=en_GB.utf8
:KDEDIRS=/usr
:LC_MEASUREMENT=en_GB.utf8
:GIT_PS1_SHOWUNTRACKEDFILES=true
:GDMSESSION=gnome
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/anton
:SHLVL=1
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=anton
:PRINTER=brno1-3rd-cafe
:QTLIB=/usr/lib64/qt-3.3/lib
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-7mbsOmI4UG,guid=a900ddf0010ccf66132eecc70000003f
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:BROWSER=google-chrome
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/anton
:DISPLAY=:0.0
:LC_TIME=en_GB.utf8
:XAUTHORITY=/var/run/gdm/auth-for-anton-S0MDkT/database
:LD_LIBRARY_PATH=/usr/java/jre1.7.0_03/lib/amd64/client:/usr/java/jre1.7.0_03/lib/amd64/server:/usr/java/jre1.7.0_03/lib/amd64/native_threads:/usr/java/jre1.7.0_03/lib/amd64

var_log_messages:
:Mar 23 09:42:27 bandura kernel: [ 6247.104768] soffice.bin[18424]: segfault at a0 ip 0000003bc9fba958 sp 00007fff1af30e50 error 4 in libvcllo.so[3bc9e00000+7dd000]
:Mar 23 09:42:28 bandura abrt[18500]: Saved core dump of pid 18424 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-03-23-09:42:27-18424 (129572864 bytes)

Comment 1 Anton Arapov 2012-03-23 09:43:14 UTC
Created attachment 572211 [details]
File: dso_list

Comment 2 Anton Arapov 2012-03-23 09:43:16 UTC
Created attachment 572212 [details]
File: maps

Comment 3 Anton Arapov 2012-03-23 09:43:19 UTC
Created attachment 572214 [details]
File: backtrace

Comment 4 Caolan McNamara 2012-03-23 12:29:54 UTC
some kind of busted lifecycle.

Was this on closing an impress frame ?

Comment 5 Anton Arapov 2012-03-26 06:16:51 UTC
I can guess only, but IIRC it was on the close of impress.

Comment 6 Michael Stahl 2012-05-25 21:07:51 UTC
*** Bug 823272 has been marked as a duplicate of this bug. ***

Comment 7 Caolan McNamara 2012-05-28 14:24:13 UTC
got to be on exit, and got to be the dtor of the "layouts" part of the right panel

Comment 8 Caolan McNamara 2012-05-29 15:57:12 UTC
But I can't reproduce it with having the layouts visible and closing impress, or activating layouts and moving elsewhere and shutting down. Nothing visible under valgrind. *maybe* this is effectively a duplicate of bug 805743 in which cases its fixed now. Or more likely there is some unknown set of circumstances that makes it crash.

If it happens for you again try and attach the presentation that was opened at the time of the crash in case its a certain amount of layouts in a presentation that's the trigger.

Comment 9 Michael Stahl 2012-12-17 20:57:43 UTC
just for the record this was most likely caused by
a bug in boost that is fixed in newer boost and
worked around in newer LibreOffice upstream.


Note You need to log in before you can comment on or make changes to this bug.