Bug 806241 - [abrt] ltrace-0.5-18.45svn.el6: address2bpstruct: Process /usr/bin/ltrace was killed by signal 6 (SIGABRT)
[abrt] ltrace-0.5-18.45svn.el6: address2bpstruct: Process /usr/bin/ltrace was...
Status: CLOSED DUPLICATE of bug 742340
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ltrace (Show other bugs)
6.3
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Petr Machata
qe-baseos-tools
abrt_hash:8b2f4d9182ac0e2c48002c67304...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-23 05:48 EDT by Michal Nowak
Modified: 2015-05-04 21:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-23 07:35:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (4.72 KB, text/plain)
2012-03-23 05:48 EDT, Michal Nowak
no flags Details
A fix (558 bytes, patch)
2012-03-23 07:33 EDT, Petr Machata
no flags Details | Diff

  None (edit)
Description Michal Nowak 2012-03-23 05:48:50 EDT
libreport version: 2.0.9
abrt_version:   2.0.8
backtrace_rating: 4
cmdline:        ltrace -o assertion.log -f eog /home/newman/runtest.svg
comment:        Tracing application which segfaulted (see bug 805466)
crash_function: address2bpstruct
environ:        
executable:     /usr/bin/ltrace
kernel:         2.6.32-251.el6.x86_64
pid:            6069
pwd:            /home/newman
reason:         Process /usr/bin/ltrace was killed by signal 6 (SIGABRT)
time:           Fri 23 Mar 2012 10:34:45 AM CET
uid:            1000
username:       newman

backtrace:      Text file, 4831 bytes

build_ids:
:7d9129177946558978ea4199d720384d3022ed50
:17b1d7503ccd3c5dbc7284a7adfdffd84b0b3329
:9f4e8e421f1a3ed6a7c19cffd0523adb4922ebde
:dc7c2ef6338bb9f3eb07e7c9e900d738ae6e6798
:fc2acfed647ac1570f36e0af02d217a4ee3119a2

dso_list:
:/usr/bin/ltrace ltrace-0.5-18.45svn.el6.x86_64 (Red Hat, Inc.) 1332176871
:/usr/lib64/libelf-0.152.so elfutils-libelf-0.152-1.el6.x86_64 (Red Hat, Inc.) 1306503148
:/usr/bin/eog eog-2.28.2-4.el6.x86_64 (Red Hat, Inc.) 1332349262
:/lib64/ld-2.12.so glibc-2.12-1.75.el6.x86_64 (Red Hat, Inc.) 1331890558
:/lib64/libc-2.12.so glibc-2.12-1.75.el6.x86_64 (Red Hat, Inc.) 1331890558

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            10485760             unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 29907                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       29907                29907                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

maps:
:00400000-00418000 r-xp 00000000 fd:01 6891                               /usr/bin/ltrace
:00617000-0061a000 rw-p 00017000 fd:01 6891                               /usr/bin/ltrace
:0061a000-0061c000 rw-p 00000000 00:00 0 
:00819000-0081b000 rw-p 00019000 fd:01 6891                               /usr/bin/ltrace
:0114f000-011d2000 rw-p 00000000 00:00 0                                  [heap]
:322f600000-322f620000 r-xp 00000000 fd:01 224                            /lib64/ld-2.12.so
:322f81f000-322f820000 r--p 0001f000 fd:01 224                            /lib64/ld-2.12.so
:322f820000-322f821000 rw-p 00020000 fd:01 224                            /lib64/ld-2.12.so
:322f821000-322f822000 rw-p 00000000 00:00 0 
:322fa00000-322fb89000 r-xp 00000000 fd:01 5587                           /lib64/libc-2.12.so
:322fb89000-322fd88000 ---p 00189000 fd:01 5587                           /lib64/libc-2.12.so
:322fd88000-322fd8c000 r--p 00188000 fd:01 5587                           /lib64/libc-2.12.so
:322fd8c000-322fd8d000 rw-p 0018c000 fd:01 5587                           /lib64/libc-2.12.so
:322fd8d000-322fd92000 rw-p 00000000 00:00 0 
:3233e00000-3233e13000 r-xp 00000000 fd:01 33162                          /usr/lib64/libelf-0.152.so
:3233e13000-3234013000 ---p 00013000 fd:01 33162                          /usr/lib64/libelf-0.152.so
:3234013000-3234014000 r--p 00013000 fd:01 33162                          /usr/lib64/libelf-0.152.so
:3234014000-3234015000 rw-p 00014000 fd:01 33162                          /usr/lib64/libelf-0.152.so
:7fd9a3d72000-7fd9a3d74000 rw-p 00000000 00:00 0 
:7fd9a3d74000-7fd9a3df1000 r--p 00000000 fd:01 27013                      /usr/bin/eog
:7fd9a3df1000-7fd9a3df4000 rw-p 00000000 00:00 0 
:7fd9a3e09000-7fd9a3e0a000 rw-p 00000000 00:00 0 
:7fff3ec99000-7fff3ecae000 rw-p 00000000 00:00 0                          [stack]
:7fff3edff000-7fff3ee00000 r-xp 00000000 00:00 0                          [vdso]
:ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0                  [vsyscall]

open_fds:
:0:/dev/pts/7
:pos:	0
:flags:	0100002
:1:/dev/pts/7
:pos:	0
:flags:	0100002
:2:/dev/pts/7
:pos:	0
:flags:	0100002
:3:/home/newman/assertion.log
:pos:	1388645
:flags:	0100001
:4:/usr/bin/eog
:pos:	0
:flags:	0100000

var_log_messages:
:Mar 19 18:06:24 dhcp-25-35 yum[25469]: Installed: ltrace-0.5-16.45svn.1.el6.x86_64
:Mar 19 18:07:51 dhcp-25-35 yum[25530]: Updated: ltrace-0.5-18.45svn.el6.x86_64
:Mar 23 10:34:45 assam abrt[6078]: Saved core dump of pid 6069 (/usr/bin/ltrace) to /var/spool/abrt/ccpp-2012-03-23-10:34:45-6069 (761856 bytes)
Comment 1 Michal Nowak 2012-03-23 05:48:54 EDT
Created attachment 572217 [details]
File: backtrace
Comment 2 Michal Nowak 2012-03-23 05:51:26 EDT
$ ltrace -o assertion.log -f eog ~/runtest.svg 
ltrace: breakpoints.c:41: address2bpstruct: Assertion `proc->leader == proc' failed.
Aborted (core dumped)


I am bit puzzled, is it sort of feature in ltrace to exit the same way trace app does, or is it a bug?
Comment 4 Petr Machata 2012-03-23 07:33:35 EDT
Created attachment 572246 [details]
A fix

This is a bug in ltrace.  It happens when the application gets SIGSEGV and ltrace tries to figure out whether it's real or whether it signals a breakpoint.  Apparently we didn't test the case where non-leader thread in a multi-threaded process dies of SIGSEGV ;)
Comment 5 Petr Machata 2012-03-23 07:35:31 EDT
Hmm, this is in fact a multi-threaded support bug, so I'll close this as duplicate.

*** This bug has been marked as a duplicate of bug 742340 ***

Note You need to log in before you can comment on or make changes to this bug.