This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 80627 - Ability to turn off "3d" mouse cursor theme.
Ability to turn off "3d" mouse cursor theme.
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-28 20:39 EST by Ivo Sarak
Modified: 2007-04-18 12:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-29 02:59:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Sarak 2002-12-28 20:39:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
Phoebe is shipping with "3d" mouse cursor theme, but implementation of it does
rise some issues and it is better to have ability to go back  to "2d" version of
this cursor.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Mouse cursor has a shadow but where does this shadow should appear? If to think
about it then the shadow will appear on the surface, and this surface is at this
case a "computer screen". So if I point or click or even worse - select
something on screen then pointing/clicking/selecting area must be at "shadow" as
"shadow" is on the surface, not the mouse cursor itself.

Actual Results:  Pointing/clicking/selecting does not follow the "screen
surface"=mouse shadow as expected.

Expected Results:  Mouse must be on "screen surface", not hovering above it or
at least go to the "surface" when selecting/clicking is performed.

Additional info:

Easier is to give user a ability to disable this "3d" mouse theme and use the
"2d" mouse theme.

(At least under KDE menus I did not find a place to disable it.)
Comment 1 Mike A. Harris 2002-12-29 02:59:49 EST
>Phoebe is shipping with "3d" mouse cursor theme, but implementation of it
>does rise some issues and it is better to have ability to go back  to "2d"
>version of this cursor.

The mouse cursors are not 3D.  The new cursors are provided by XFree86.org,
and use the new Xcursor library by Keith Packard.  The cursors themselves
are truecolor cursor images which contain an alpha channel.  The alpha
channel allows the cursors to contain translucent pixels, which is what
how the "shadow" effect is done.  The mouse shadow is not done by software,
but is part of the actual cursor image itself, so you can not just turn it
off as it isn't a software effect.

If you do not like the default cursor theme, you can disable it.  Bugzilla
is not a technical support forum however, so I will leave that question
to the xpert@xfree86.org mailing list to answer.

Mouse cursor has a shadow but where does this shadow should appear? If to think
about it then the shadow will appear on the surface, and this surface is at this
case a "computer screen". So if I point or click or even worse - select
something on screen then pointing/clicking/selecting area must be at "shadow" as
"shadow" is on the surface, not the mouse cursor itself.

Actual Results:  Pointing/clicking/selecting does not follow the "screen
surface"=mouse shadow as expected.

Expected Results:  Mouse must be on "screen surface", not hovering above it or
at least go to the "surface" when selecting/clicking is performed.

Additional info:

>Easier is to give user a ability to disable this "3d" mouse theme and
>use the "2d" mouse theme.
>
>(At least under KDE menus I did not find a place to disable it.)

As stated above, the mouse cursors are not 3D.  They are png images which
have an alpha channel.  XFree86 provides the library interface to allow
color alpha blended antialiased animated themeable mouse cursors.  There
are 2 themes provided by XFree86.org currently, however people are free
to create their own cursor images as well. People are free to also use the
legacy monochrome cursors if they choose to as well.

>Mouse cursor has a shadow but where does this shadow should appear?
>If to think about it then the shadow will appear on the surface, and
>this surface is at this case a "computer screen". So if I point or
>click or even worse - select something on screen then >pointing/clicking/selecting
>area must be at "shadow" as "shadow" is on the surface, not the mouse
>cursor itself.

No, there is no "shadow" on the mouse cursor.  It is completely an
illusion.  The so called "shadow" is part of the mouse cursor image
itself.  The "shadow" portion of the cursor image is of a lighter shade
of the standard cursor image and is offset in the image to the right
and down a bit, and also has an alpha component which makes it translucent.
This makes it appear to be a shadow, however it is not.  It is a fixed
part of the cursor image, and it can not be disabled, nor can it be moved.
The only way to disable it or move it is to make your own cursor images
in the gimp, and use xcursorgen to create your own cursor theme.

Of course that process is a developmental issue and not a bug.  I'm closing
this as NOTABUG because I see no bug being reported here.  If you want to
know how to manipulate, change or enable/disable cursor themes, you should
join the xpert@xfree86.org mailing list, and post questions there.  Someone
will likely be glad to help you reconfigure XFree86 to use the cursor style
that you prefer.  We will possibly have a GUI cursor theme generator at some
point also, but the lack of one is not a bug.

Closing as NOTABUG



  
Comment 2 Ivo Sarak 2002-12-29 04:58:45 EST
Where does I say "it is a bug"?
I set the severity as "enhancement" and all was I asking for was a "ability
change the mouse cursor theme".

Resolution of this report can be "closed wontfix" not a "closed notabug", but as
You stated "someday RH may have tool for that", then it is RFE.
Comment 3 Mike A. Harris 2002-12-29 05:22:53 EST
Sorry, I did not see the enhancement categorization.

However, you are suggesting that the shadow of the cursor be where the
hotspot is located.  That is just totally broken.  First of all, the
shadow as mentioned above, is not a real shadow, but is merely part
of the mouse cursor itself.  Think if the pseudo-shadow mouse cursor
were to be the hot spot of the pointer - what then would be the point
of the real cursor itself?  That makes no sense.  The mouse cursor itself
is what the hotspot is and should be tied to.  The pseudo-cursor created
via an offset faded alpha of the main pointer image is just a graphic
effect, and should not ever be the hotspot.  That will not ever be
implemented as an enhancement or otherwise.

A utility for changing mouse cursor themes however is indeed something
which is likely to exist in the future, however not as part of XFree86
itself.  What you seek is a GNOME and/or KDE utility for choosing mouse
cursors, and such a utility should not be requested as an enhancement for
XFree86, but would be something requested of the GNOME and/or KDE projects
directly upstream, or made against the "distribution" component if requesting
something like that from Red Hat directly.

So, I don't disagree with your request to have a GUI utility to choose
the cursor, however as I've said, it will indeed occur at some point.  I
could in theory reassign this request to "distribution" or to "kdebase"
or "gnome-core", however since it is something that the developers are
already quite aware of, it isn't something really that needs to be tracked
directly in Red Hat bugzilla.

Rest assured that:

1) There will be a GUI method of changing mouse cursor themes at some point
2) You will not see the mouse pseudo-shadow contain the hotspot in any cursors
   that ship in Red Hat Linux, as that does not do what most users would expect,
   and would cause great confusion.  You are free however to edit the cursor
   definition files yourself, run xcursorgen and make customized cursors for
   yourself that do this.

Comment 4 Ivo Sarak 2002-12-29 09:09:48 EST
Thank You for Your explanations. 

As this "pseudo shadow" will most definitely cause confusion about where is and
should be the mousepointer hotspot for other users of RedHat GNU/Linux it should
be removed/fixed, but let say it is only my problem at the moment and I try to
find a way to "fix" it for myself.

RedHat is in better position to persuade/talk to/... XFree86/KDE/GNOME than some
"average Joe" from "who knows where".

Note You need to log in before you can comment on or make changes to this bug.