Bug 806300 - info block shows backing file still exists after stream the entire chain
info block shows backing file still exists after stream the entire chain
Status: CLOSED DUPLICATE of bug 801449
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Marcelo Tosatti
Virtualization Bugs
: Reopened
Depends On:
Blocks: 806280
  Show dependency treegraph
 
Reported: 2012-03-23 07:58 EDT by Shaolong Hu
Modified: 2013-01-09 19:48 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-26 09:01:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shaolong Hu 2012-03-23 07:58:27 EDT
Description of problem:
------------------------
after stream the entire chain, backing file still exists in info block output.


Version-Release number of selected component (if applicable):
--------------------------------------------------------------
qemu-kvm-0.12.1.2-2.262.el6rhev.x86_64


How reproducible:
-----------------
100%


Steps to Reproduce:
--------------------
1.(qemu) info block
drive-virtio-disk0: removable=0 io-status=ok file=/root/RHEL-Server-6.3-64-virtio.qcow2 ro=0 drv=qcow2 encrypted=0

2.(qemu) snapshot_blkdev drive-virtio-disk0 /root/sn1 qcow2
Formatting '/root/sn1', fmt=qcow2 size=21474836480 backing_file='/root/RHEL-Server-6.3-64-virtio.qcow2' backing_fmt='qcow2' encryption=off cluster_size=65536 
(qemu) info block
drive-virtio-disk0: removable=0 io-status=ok file=/root/sn1 backing_file=/root/RHEL-Server-6.3-64-virtio.qcow2 ro=0 drv=qcow2 encrypted=0

3.(qemu) block_stream drive-virtio-disk0 

4.(qemu) info block-jobs 
No active jobs
(qemu) info block
drive-virtio-disk0: removable=0 io-status=ok file=/root/sn1 backing_file=/root/RHEL-Server-6.3-64-virtio.qcow2 ro=0 drv=qcow2 encrypted=0

5. quit qemu-kvm.

6.[root@shu ~]# qemu-img info sn1
image: sn1
file format: qcow2
virtual size: 20G (21474836480 bytes)
disk size: 20G
cluster_size: 65536


Expected results:
------------------
After block stream finishes, set backing file as null.
Comment 2 Dor Laor 2012-03-25 06:26:29 EDT
IIUC it creates another qcow2 file on top of the existing one so that's the expected behavior. Marcelo can verify it
Comment 3 Kevin Wolf 2012-03-26 05:19:16 EDT
This is a valid bug report.

bdrv_change_backing_file() was not designed to work from the system emulator and change the BlockDriverState accordingly. It needs to be extended to update bs.
Comment 4 Marcelo Tosatti 2012-03-26 09:00:31 EDT
The fix for BZ #801449 adjusts bs->backing_file correctly. Marking it as a duplicate of that bug.
Comment 5 Marcelo Tosatti 2012-03-26 09:01:28 EDT

*** This bug has been marked as a duplicate of bug 801449 ***

Note You need to log in before you can comment on or make changes to this bug.