Bug 806312 - block stream touches all qcow2 image cluster
block stream touches all qcow2 image cluster
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks: 806280
  Show dependency treegraph
 
Reported: 2012-03-23 08:16 EDT by Shaolong Hu
Modified: 2012-03-23 09:41 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-23 09:41:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shaolong Hu 2012-03-23 08:16:46 EDT
Description of problem:
------------------------
After block stream, qcow2 image disk size reaches to virtual size.


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
qemu-kvm-0.12.1.2-2.262.el6rhev.x86_64


How reproducible:
-----------------
100%


Steps to Reproduce:
--------------------
1.(qemu) info block
drive-virtio-disk0: removable=0 io-status=ok file=/root/RHEL-Server-6.3-64-virtio.qcow2 ro=0 drv=qcow2 encrypted=0

2.(qemu) snapshot_blkdev drive-virtio-disk0 /root/sn1 qcow2

3.(qemu) block_stream drive-virtio-disk0

4.[root@shu ~]# qemu-img info sn1
image: sn1
file format: qcow2
virtual size: 20G (21474836480 bytes)
disk size: 20G
cluster_size: 65536

5.[root@shu ~]# qemu-img info RHEL-Server-6.3-64-virtio.qcow2 
image: RHEL-Server-6.3-64-virtio.qcow2
file format: qcow2
virtual size: 20G (21474836480 bytes)
disk size: 4.5G
cluster_size: 65536

  
Expected results:
------------------
Hi, i am not sure whether this is a bug, if not, please explain a little bit, and i highly recommend this as a RFE if can not be solved in 6.3, for streaming is mainly used by customer to update or re-arrange their storage, they probably don't want to see that after migrating to a larger storage, there is still no space left.
Comment 2 Kevin Wolf 2012-03-23 09:41:04 EDT
This is expected, only QED supports streaming efficiently today. We will fix this with an image format extension ("qcow3") in RHEL 7.

Note You need to log in before you can comment on or make changes to this bug.