Bug 806327 - bootindex not work on scsi-disk if there is QEMU emulated usb-storage in cli
bootindex not work on scsi-disk if there is QEMU emulated usb-storage in cli
Status: CLOSED DUPLICATE of bug 782029
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Paolo Bonzini
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-23 08:54 EDT by Chao Yang
Modified: 2013-01-09 19:48 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-28 16:22:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Chao Yang 2012-04-01 07:05:55 EDT
same issue exists on ide-drive/virtio-scsi and virtio-blk-pci/virtio-scsi
Comment 3 Paolo Bonzini 2012-04-02 03:06:31 EDT
Please be more specific.  From bug 801293 comment 4:

"In general if you specify bootindex for one disk you want to specify it for all
of them, including usb-storage."  Otherwise the decisions from SeaBIOS can be confusing.
Comment 4 Chao Yang 2012-04-05 01:16:01 EDT
(In reply to comment #3)
> Please be more specific.  From bug 801293 comment 4:
> 
> "In general if you specify bootindex for one disk you want to specify it for
> all
> of them, including usb-storage."  Otherwise the decisions from SeaBIOS can be
> confusing.

This bug is opened to tract bug 801293 comment 7.
Comment 5 Paolo Bonzini 2012-04-05 12:08:50 EDT
Sorry, I didn't see bug 801293 comment 9. Do you have the new command-line.  Do you have the command-line?  Also, what does the boot menu say?
Comment 6 Chao Yang 2012-04-09 01:51:48 EDT
(In reply to comment #5)
> Sorry, I didn't see bug 801293 comment 9. Do you have the new command-line.  Do
> you have the command-line?  Also, what does the boot menu say?
With seabios-0.6.1.2-15.el6.x86_64, qemu-kvm-0.12.1.2-2.269.el6.x86_64

# /usr/libexec/qemu-kvm -M rhel6.3.0 -cpu SandyBridge -enable-kvm -m 2048 -smp 2,sockets=1,cores=2,threads=1 -boot menu=on -rtc base=utc,clock=host,driftfix=slew -drive file=/home/rhel6.3_20120313_x86_64_copy.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,serial=69-a2ad-85f195fee049,cache=none,werror=stop,rerror=stop,aio=native -device virtio-scsi-pci,id=scsi-pci -device scsi-disk,drive=drive-virtio-disk0,id=virtio-disk0,bus=scsi-pci.0,lun=0,bootindex=1  <---
-net none -spice port=8000,disable-ticketing -k en-us -vga qxl -global qxl-vga.vram_size=67108864 -device usb-ehci,id=ehci -drive file=/home/RHEL-Server-6.3-64-virtio.qcow2,if=none,id=drive-virtio-disk1,format=qcow2,cache=none,werror=stop,rerror=stop,aio=native -device usb-storage,bus=ehci.0,port=1,drive=drive-virtio-disk1,id=virtio-disk1,removable=on,bootindex=2  <---
-device sga -serial stdio

Google, Inc.
Serial Graphics Adapter 07/26/11
SGABIOS $Id: sgabios.S 8 2010-04-22 00:03:40Z nlaredo $ (mockbuild@hs20-bc2-3.build.redhat.com) Tue Jul 26 15:05:08 UTC 2011
4 0
SeaBIOS (version seabios-0.6.1.2-15.el6)

Press F12 for boot menu.

Select boot device:

1. USB MSC Drive QEMU QEMU HARDDISK 0.12
2. virtio-scsi Drive QEMU QEMU HARDDISK 0.12
3. DVD/CD [ata1-0: QEMU DVD-ROM ATAPI-4 DVD/CD]
4. Legacy option rom
Comment 7 Paolo Bonzini 2012-05-16 11:01:17 EDT
This could be fixed in qemu-kvm-0.12.1.2-2.294.el6; two patches were missing when bug 802284 was committed to distgit.
Comment 8 Paolo Bonzini 2012-05-28 16:22:08 EDT

*** This bug has been marked as a duplicate of bug 782029 ***

Note You need to log in before you can comment on or make changes to this bug.