Bug 806342 - dhclient segfault
dhclient segfault
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
17
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-23 09:42 EDT by Joel Kirchmeyer
Modified: 2012-04-11 22:35 EDT (History)
1 user (show)

See Also:
Fixed In Version: dhcp-4.2.3-24.P2.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-11 22:35:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
From gdb (3.18 KB, text/plain)
2012-03-23 11:07 EDT, Joel Kirchmeyer
no flags Details
From abrt (237.31 KB, application/x-xz)
2012-03-23 11:07 EDT, Joel Kirchmeyer
no flags Details
abrt - from 4.2.3-23.P2.fc17 (238.02 KB, application/x-xz)
2012-03-23 14:41 EDT, Joel Kirchmeyer
no flags Details

  None (edit)
Description Joel Kirchmeyer 2012-03-23 09:42:26 EDT
Description of problem:
When connecting any network card ( wireless or ethernet ) dhclient segfaults


Version-Release number of selected component (if applicable):
4.2.3-22.P2.fc17.x86_64
4.2.3-21.P2.fc17.x86_64
4.2.3-20.P2.fc17.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Update to any of the listed versions of dhclient, dhcp-common, dhcp-libs
2. Connect to network
  
Actual results:
4.2.3-22.P2.fc17.x86_64 - kernel: dhclient[1078]: segfault at 0 ip 00007f876e29dd1f sp 00007fffc04749d0 error 4 in dhclient[7f876e275000+62000]
4.2.3-21.P2.fc17.x86_64 - kernel: dhclient[2637]: segfault at 0 ip 00007f29cede1c4f sp 00007fff576dd4e0 error 4 in dhclient[7f29cedb9000+62000]
4.2.3-20.P2.fc17.x86_64 - kernel: dhclient[2747]: segfault at 0 ip 00007fa600ec3c4f sp 00007fff44883670 error 4 in dhclient[7fa600e9b000+62000]
Expected results:


Additional info:
Comment 1 Jiri Popelka 2012-03-23 10:02:59 EDT
Thanks,

I unpushed the update
https://admin.fedoraproject.org/updates/FEDORA-2012-4532/dhcp-4.2.3-22.P2.fc17
and will look at this.
Comment 2 Jiri Popelka 2012-03-23 10:33:23 EDT
Hmm, that's strange because I've been running (locally built) 4.2.3-22.P2 on my production F16 machine since yesterday and now also the packages from the update on F17 virtual machine and have seen no problems. Both are x86_64.

I need you to provide some more info about your network configuration, like:
- your /etc/sysconfig/network-scripts/ifcfg-<iface> file
- do you run NetworkManager ?

And I would probably need to see a stack trace, it would be awesome if you can get one, see http://fedoraproject.org/wiki/StackTraces
Comment 3 Joel Kirchmeyer 2012-03-23 11:07:25 EDT
Created attachment 572300 [details]
From gdb

As requested.
Comment 4 Joel Kirchmeyer 2012-03-23 11:07:44 EDT
Created attachment 572301 [details]
From abrt
Comment 5 Joel Kirchmeyer 2012-03-23 11:08:29 EDT
-I do use NetworkManager.
-There is no ifcfg file for p5p1
Comment 6 Jiri Popelka 2012-03-23 13:47:04 EDT
Thanks, the core dump (in abrt attachment) has been very useful.
Could you try this build ?
http://koji.fedoraproject.org/koji/taskinfo?taskID=3926932

Just out of curiosity:
There seems to be some "teql0" interface on your system, do you have any idea what it is ?
Comment 7 Fedora Update System 2012-03-23 14:18:47 EDT
dhcp-4.2.3-23.P2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dhcp-4.2.3-23.P2.fc17
Comment 8 Joel Kirchmeyer 2012-03-23 14:41:15 EDT
Created attachment 572364 [details]
abrt - from 4.2.3-23.P2.fc17

Sigfault with new version.
Comment 9 Jiri Popelka 2012-03-23 15:22:01 EDT
omg ;-)

ok, scratch-build this time:
http://koji.fedoraproject.org/koji/taskinfo?taskID=3927599

thank you
Comment 10 Joel Kirchmeyer 2012-03-23 15:37:45 EDT
That fixed it. :)
Comment 11 Fedora Update System 2012-03-24 13:43:31 EDT
Package dhcp-4.2.3-24.P2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dhcp-4.2.3-24.P2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4645/dhcp-4.2.3-24.P2.fc17
then log in and leave karma (feedback).
Comment 12 Jiri Popelka 2012-03-26 13:27:15 EDT
Joel,
I have one more improvement and I'll be glad if you could give it a try. Thanks.
http://koji.fedoraproject.org/koji/taskinfo?taskID=3934015
Comment 13 Joel Kirchmeyer 2012-03-26 13:40:15 EDT
All is well with 4.2.3-24.1.P2.fc17 as far as I can tell.
Comment 14 Fedora Update System 2012-04-11 22:35:26 EDT
dhcp-4.2.3-24.P2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.