Bug 806402 - [REST API] application 'port' response element
[REST API] application 'port' response element
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Master (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Krishna Raman
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-23 12:07 EDT by Xavier Coulon
Modified: 2015-05-14 20:51 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 19:56:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xavier Coulon 2012-03-23 12:07:26 EDT
As in the case of aliases, the port could be considered as a subresource of an application, with links to 'show', 'conceal' and 'expose'.
also, 'show' operation could be mapped on a HTTP 'GET' method, since the semantic of the 'show-port' operation is more close to a 'query' than a change in the application configuration.
Comment 1 Abhishek Gupta 2013-01-28 18:30:08 EST
The rest api no longer handles show, expose, and conceal port events. This bug (or enhancement request) is no longer valid.

Marking it ON_QA to be closed.
Comment 2 Rony Gong 2013-01-29 21:54:05 EST
Tested on devenv_2743
curl -k -X GET -H 'Accept: application/xml' --user qgong@redhat.com:111111 https://ec2-23-22-111-162.compute-1.amazonaws.com/broker/rest/domains/qgong8/applications/qsphp
The rest api no longer handles show, expose, and conceal port events

Note You need to log in before you can comment on or make changes to this bug.