Bug 806428 - deadline support for user task nodes
Summary: deadline support for user task nodes
Keywords:
Status: VERIFIED
Alias: None
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: jBPM 5
Version: BRMS 5.3.0.GA
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER4
: BRMS 5.3.1 GA
Assignee: Tihomir Surdilovic
QA Contact: Marek Baluch
URL:
Whiteboard:
Depends On:
Blocks: 867819
TreeView+ depends on / blocked
 
Reported: 2012-03-23 17:34 UTC by Jeffrey Bride
Modified: 2020-04-27 01:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, there was no support for deadlines and notifications in user task nodes when working with the process designer, this prevented users from specifying deadlines or notifications. This has been resolved and users can now specify deadlines and notifications.
Clone Of:
: 867819 (view as bug list)
Environment:
Last Closed:
Type: ---


Attachments (Terms of Use)
HumanTaskDeadline.bpmn (6.57 KB, text/plain)
2012-11-13 10:25 UTC, Jiri Svitak
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat One Jira Issue Tracker JBPM-3575 Major Resolved Deadline/escalation support for user task nodes 2015-12-04 14:57:10 UTC

Description Jeffrey Bride 2012-03-23 17:34:58 UTC
This BZ corresponds to :
   https://issues.jboss.org/browse/JBPM-3575
   https://github.com/droolsjbpm/jbpm/pull/55

It would be of great value to have this deadline functionality included in BRMS 5.3 .

thank you!

jeff

Comment 1 Maciej Swiderski 2012-04-02 09:48:53 UTC
Pull requests for all components are available at
jbpm: https://github.com/droolsjbpm/jbpm/pull/55
eclipse editor: https://github.com/droolsjbpm/droolsjbpm-tools/pull/9
designer: https://github.com/tsurdilo/process-designer/pull/5

Comment 2 Kris Verlaenen 2012-04-15 21:39:12 UTC
jbpm and eclipse pull request have been merged

Comment 3 Lukáš Petrovický 2012-10-17 07:54:11 UTC
Setting this as ON_QA so that it isn't missed.

Comment 4 Jiri Svitak 2012-10-22 08:20:35 UTC
The engine part of the bug fix has been verified.

However, I could not found the fix for the Designer. After further investigation I have noticed that the pull request for the fix is still open in the old repository:
https://github.com/tsurdilo/process-designer/pull/5

Please fix the issue in the master and product branch of the Designer.

Comment 5 Tihomir Surdilovic 2012-10-23 11:57:19 UTC
We have decided to partially use the pull request however implement custom editors for data inputs. This is still on-going work in the community.

Comment 8 lcarlon 2012-10-25 23:37:52 UTC
This issue has been marked as requires_doc_text, however, no text has been provided. Please provide the text so it can be added to the release notes document, or set the requires_doc_text flag to '-'.

Thanks
Lee

Comment 9 Tihomir Surdilovic 2012-10-30 13:26:05 UTC
deadline and notification support is being added to designer.

Comment 10 Tihomir Surdilovic 2012-11-01 13:48:09 UTC
added to designer product 2.3.x branch.

Comment 11 Jiri Svitak 2012-11-13 10:25:22 UTC
Created attachment 644043 [details]
HumanTaskDeadline.bpmn

As said before the engine part is already fixed. I've tried to test changes in Designer and new human task items have been added - Notifications and Reassignment. However, only manipulation with Reassignment works. I was not able to add new notifications, only delete existing ones.

I have used the attached business process for testing, it's from the community commit for this feature. I have also tried my own business process created from scratch, but still I was not able to add new notifications.

Comment 12 Tihomir Surdilovic 2012-11-13 13:26:17 UTC
I think the problem is the comma in your expires at value of the entry 2s,4s. There should be a single value in this column.

Comment 13 Jiri Svitak 2012-11-13 13:46:57 UTC
No, as I said I tried to configure notifications also with new empty process. Even with single value 2s it was not possible to add a notification. Either the Designer should save it or tell the user why this notification cannot be saved.

Comment 14 Tihomir Surdilovic 2012-11-13 14:30:13 UTC
Reading this thread I don't see prior discussions of this particular issue so not sure what the repeated "as i said" really mean or try to accomplish?
 
Can you please link me the URL where I can download the ER build so can test locally and fix?

Thanks.

Comment 15 Jiri Svitak 2012-11-13 16:35:51 UTC
I refer to my previous post. Just wanted to explain that it doesn't matter if there are commas or not, because either of those options means that you currently cannot add notifications.

Here are the links for ER4:
Europe - http://jawa05.englab.brq.redhat.com/candidate/BRMS-5.3.1-ER4/
US - http://download.lab.bos.redhat.com/brewroot/packages/org.jboss-brms-p/5.3.1.ER4/3/maven/org/jboss/brms-p/5.3.1.ER4/

Comment 16 Tihomir Surdilovic 2012-11-13 20:52:10 UTC
Thank you, tested with ER4 and comma in the expires value seems to be breaking the parsing. If you remove it things works as expected. I am on ER4 also able to add new notifications without issues. Try clearing your browser cache and try again.

Comment 17 Tihomir Surdilovic 2012-11-13 20:55:26 UTC
Thank you, tested with ER4 and comma in the expires value seems to be breaking the parsing. If you remove it things works as expected. I am on ER4 also able to add new notifications without issues. Try clearing your browser cache and try again.

Comment 18 Tihomir Surdilovic 2012-11-15 14:18:27 UTC
Could I please get a response on the last comment?

Thanks.

Comment 19 Jiri Svitak 2012-11-15 15:35:53 UTC
I have cleared my browser cache, but it did not help. Even if I forget on the attached business process and use another new process the problem persists. I cannot add any notification to human task node notifications. I have noticed that there are small red triangles for columns:
Expires At, From, To Users, To Groups, Reply To, Subject
What these small red triangles mean?
Also I was not able to add body to notification in the bigger editor for message body.

Returning back to the attached business process created by Maciej. Have you asked Maciej about the commas in the "Expires At" column? I can confirm that changing the existing two notifications is possible. Cannot add third notification there though.

So it's not possible to add new notifications in new processes. Existing saved notifications seems to be possible to edit.

Comment 20 Lukáš Petrovický 2012-11-15 15:39:24 UTC
I have double-checked all the findings (see comment 19), using a fresh Firefox profile. (= No cache at all.)

We have tested this on both EAP5 and EAP6, with the same results on both.

Comment 21 Tihomir Surdilovic 2012-11-19 17:25:15 UTC
The red triangle means that that column cannot be blank or that the value has changed. Can you please give me steps to reproduce this issue? Neither Maciej nor I are able to reproduce on ER4.

Currently you cannot leave to users , to groups, subject and body as blank. if you do designer will ignore your entry (we should probably show an alert message here for users rather than just ignore - please open a BZ for that).

Comment 22 Jiri Svitak 2012-11-21 13:08:11 UTC
Hello,

I will write again the steps to reproduce the problem:
1.) Download brms-p-5.3.1.ER4-deployable-ee6.zip from http://jawa05.englab.brq.redhat.com/candidate/BRMS-5.3.1-ER4/.
MD5 hash and name of the file:
225bf1b40a1190acfa3267f4c7c2c10b  brms-p-5.3.1.ER4-deployable-ee6.zip
2.) Download EAP 6 from here:
http://download.eng.brq.redhat.com/released/JBEAP-6/6.0.0/zip/
3.) I have deployed the brms 5.3.1 ER4 ee6 into EAP6, you can use this guide for that (default human task users and groups, default console users and groups, persistence using MySQL 5.5):
https://docspace.corp.redhat.com/docs/DOC-111367
4.) Start the server in standalone mode: jboss-eap-6.0/bin/standalone.sh
5.) Create .dodeploy files for all jBPM .war directories in jboss-eap-6.0/standalone/deployments.
6.) Open Firefox 12.0, click on Tools->Clear Recent History, check Cache to be deletede, time range Everything.
7.) Open new tab and type the address:
http://localhost:8080/jboss-brms/
8.) Log in as user krisv, password krisv.
9.) Click on Knowledge Bases on the left panel.
10.) Click on Create New->New Package.
11.) Fill in the name of the package com.sample and click Create package.
12.) Click on Create New->New BPMN2 Process.
13.) Fill in the name HumanTask and Create in Package com.sample.
14.) HumanTask process is opened in Designer. Click on the left panel and place on the canvas ordinary StartEvent. Add a human task. Add an end event.
15.) Click on the human task. Fill in Name: Human Task, TaskType: User, Actors: krisv, Task Name: HumanTask.
16.) Click on PNG on the bottom panel to generate process image. Generate task forms for human tasks. Click on Validate button, all should validate without problems.
17.) Click on File->Save changes->Check in.
18.) Click again on HumanTask, open right panel and click on Notifications.
19.) Fill in type: Not Started, Expises At: 10s, From: krisv, To Users: mary, To Groups: PM, Subject: subject.
20.) Try to fill Body, the editor is opened. Fill in "body" and click on OK. String "body" is not saved.
21.) Try to save the rest of the notification with filled fields Type, From, To Users, To Groups, Subject.
22.) The notification did not save. 

NEW FINDINGS:
However later I have noticed another editor for the Body. I think that this is the core problem. Two editors for body of the notification have been opened. After I closed the second body editor, which was hidden behind other dialogs, I was able to add a notification on second attempt without problems.

Why there are two Body editors opened? It prevents from saving the body of the notification and then it prevents from saving the notification itself. After the first unsuccessful attempt I was able to add new notifications without problems.

I see two following problem now:
user friendliness - user doesn't know which fields are mandatory, no warnings or validations are available
- two editors for Body notification can be opened and user can easily miss this fact and thinks that it's impossible to add a notification

POSSIBLE SOLUTION:
I think we can agree that there is no time for implementing the validation or program help for the mandatory parameters of notifications.
Regarding the second problem - if you have two editors for "Body" opened, please try to fix it - that only one correct editor is opened, which is able to save the body of the notification. If you cannot see this problem, then don't fix it and we'll leave this bug.

Comment 23 Tihomir Surdilovic 2012-11-21 16:57:58 UTC
Thank you for detailed description and _very_ nice catch!
Notifications editor is no longer able to show multiple body input editors.

Fixed and checked into Designer 2.3.x branch

Comment 24 Jiri Svitak 2012-12-03 11:50:00 UTC
Verified in BRMS 5.3.1 CR1.


Note You need to log in before you can comment on or make changes to this bug.