Bug 806452 - Update Kernel 3.3.0-4.fc16 breaks Intel Wireless-N 1000
Update Kernel 3.3.0-4.fc16 breaks Intel Wireless-N 1000
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-23 15:27 EDT by privat
Modified: 2012-04-03 20:33 EDT (History)
5 users (show)

See Also:
Fixed In Version: 3.3.0-8.fc16.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-03 20:33:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output after 6 reconnect circles (123.24 KB, text/plain)
2012-04-03 16:34 EDT, privat
no flags Details
dmesg with one additional circle with wd_disable=1 (123.33 KB, text/plain)
2012-04-03 16:36 EDT, privat
no flags Details

  None (edit)
Description privat 2012-03-23 15:27:38 EDT
Description of problem:
The updated Kernel 3.3.0-4.fc16 breaks connectivity with Intel Wireless-N 1000. I am able to connect to my W-Lan (WPA2-PSK) but after 10-20 seconds it disconnects and reconnects normally again just to disconnect again. This cyclus keeps repeating as long as the Device is active.
In the time the connection is actually connected it works normal.

It works without (significant) problems under Kernel 3.2.7-1


Version-Release number of selected component (if applicable):
Kernel 3.3.0-4.fc16.x86_64


How reproducible:
Everytime


Steps to Reproduce:
1.Boot kernel 3.3.0
2.Connect to WPA2 protected Wlan
3.Observerve continued disconnects
  
Actual results:
Unstable and unusable Connection.

Expected results:
Stable connection like in Kernel 3.2.7

Additional info:
lspci -s 03:00.0:
03:00.0 Network controller: Intel Corporation Centrino Wireless-N 1000

P.S.: This is my first Bug report so it is probably not so well made.
Comment 1 John W. Linville 2012-03-26 10:28:54 EDT
Can we see the output from 'dmesg' after a few disconnects?

Have you tried using the 'wd_disable=1' option when loading the iwlwifi module?
Comment 2 privat 2012-03-26 12:23:47 EDT
ok just discovered one oddity:

It seems to only occur when I use the Speedport W722v at my girlfriend's place, while the Speedport W701v at my home works fine.
So the problem Is still that with 3.3 the connection is unstable but that is Access point dependent.

The bad part: it will be about 2 weeks before I can reproduce the error to cap dmesg.
Comment 3 privat 2012-04-03 16:34:48 EDT
Created attachment 574977 [details]
dmesg output after 6 reconnect circles

This is the dmesg output after 6 reconnect circles. The module iwlwifi has not been loaded with special options.
Comment 4 privat 2012-04-03 16:36:52 EDT
Created attachment 574978 [details]
dmesg with one additional circle with wd_disable=1

This is the dmesg output after the iwlwifi module has been reloaded with wd_disable=1 and one reconnect circle has happend.
Comment 5 privat 2012-04-03 16:38:51 EDT
I attached the requested output. Reloading the module with "wd_disable=1" did not change the reconnecting behavior.
Comment 6 privat 2012-04-03 18:24:18 EDT
ok the kernel version 3.3.0-8.fc16.x86_64 fixed it.
Comment 7 Josh Boyer 2012-04-03 20:33:27 EDT
OK, thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.