Bug 80646 - (ET4000) X server does not start during installation
Summary: (ET4000) X server does not start during installation
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 9
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-29 14:07 UTC by Bernhard Erdmann
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-10 16:39:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X11 server config file as generated by installer (3.18 KB, text/plain)
2003-01-02 03:25 UTC, Bernhard Erdmann
no flags Details
X server logfile /var/log/XFree86.0.log (33.15 KB, text/plain)
2003-01-02 03:26 UTC, Bernhard Erdmann
no flags Details
X server setup logfile /var/log/XFree86.setup.log (5.75 KB, text/plain)
2003-01-02 03:27 UTC, Bernhard Erdmann
no flags Details
output of lspci -vv (2.97 KB, text/plain)
2003-01-22 11:11 UTC, Bernhard Erdmann
no flags Details
output of lspci -vvn (2.62 KB, text/plain)
2003-01-22 11:12 UTC, Bernhard Erdmann
no flags Details
working box: /var/log/XFree86.0.log (30.81 KB, text/plain)
2003-01-29 21:47 UTC, Bernhard Erdmann
no flags Details
working box: /etc/X11/XF86Config (3.20 KB, text/plain)
2003-01-29 21:48 UTC, Bernhard Erdmann
no flags Details
working box: lspci -vv (4.70 KB, text/plain)
2003-01-29 21:49 UTC, Bernhard Erdmann
no flags Details
working box: lspci -vvn (4.09 KB, text/plain)
2003-01-29 21:50 UTC, Bernhard Erdmann
no flags Details

Description Bernhard Erdmann 2002-12-29 14:07:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; IRIX64 IP28; en-US; rv:1.3b) Gecko/20021228

Description of problem:
When trying to start the X server during graphical install mode, anaconda crashes.

The video card is ET4000 something and RedHat 8.0 has no problems passing this
point.

Anaconda's output:

Probing for video card: ET4000 W32i, W32p (generic)
Probing for monitor type: Unknown monitor
Probing for mouse type: Generic 3 button mouse (PS/2)
Attempting to start native X server
Waiting for X server to start... log located in /tmp/X.log
1..2..3..4..5  X server started successfully
XIO: fatal IO error 104 (Connection reset by peer) on X server ":1.0"
     after 0 requests (0 known processed) with 0 events remaining
install exited abnormally

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. put in an ET4000/W32 card
2. start installer in graphical mode
3. wait for starting the X server
    

Additional info:

Comment 1 Mike A. Harris 2003-01-01 23:47:06 UTC
Please do a text mode install, and then run redhat-config-xfree86 by hand
afterward.  Try starting X, and then please attach your X server log and
config file individually as separate file attachments below.

Comment 2 Bernhard Erdmann 2003-01-02 03:25:30 UTC
Created attachment 89043 [details]
X11 server config file as generated by installer

Comment 3 Bernhard Erdmann 2003-01-02 03:26:24 UTC
Created attachment 89044 [details]
X server logfile /var/log/XFree86.0.log

Comment 4 Bernhard Erdmann 2003-01-02 03:27:30 UTC
Created attachment 89045 [details]
X server setup logfile /var/log/XFree86.setup.log

Comment 5 Mike A. Harris 2003-01-22 09:47:29 UTC
This problem is most likely motherboard specific.  Your motherboard/system
seems to be rather special compared to other generic systems.  Is it a
server machine of some kind?  This problem is most likely something to do
with PCI domains.  It's possible even that the tseng driver code hasn't
been updated to use the new PCI domains code in X.

Could you post the output of:  "lspci -vvn" and "lspci -vv" also please?
This might help to determine where things are going wrong.

Also, if you have another machine available that you could possibly test
this ET4000 in, and are willing to give it a shot, it might help us to
narrow things down too.  If you can do this, please attach the log and
config file from the other machine too, indicating if the card works in
it or not.

TIA

Comment 6 Bernhard Erdmann 2003-01-22 11:11:36 UTC
Created attachment 89511 [details]
output of lspci -vv

Comment 7 Bernhard Erdmann 2003-01-22 11:12:55 UTC
Created attachment 89512 [details]
output of lspci -vvn

Comment 8 Bernhard Erdmann 2003-01-29 21:45:29 UTC
I've put this ET4000 in another box (AMD K6/400, DFI mainboard) and the
installer runs well. No problem to fire up X.

The board with ET4000 problems is a NMC 5VxC.

I'll attach X log and lspci of the working box.

Comment 9 Bernhard Erdmann 2003-01-29 21:47:58 UTC
Created attachment 89692 [details]
working box: /var/log/XFree86.0.log

Comment 10 Bernhard Erdmann 2003-01-29 21:48:49 UTC
Created attachment 89693 [details]
working box: /etc/X11/XF86Config

Comment 11 Bernhard Erdmann 2003-01-29 21:49:44 UTC
Created attachment 89694 [details]
working box: lspci -vv

Comment 12 Bernhard Erdmann 2003-01-29 21:50:30 UTC
Created attachment 89695 [details]
working box: lspci -vvn

Comment 13 Mike A. Harris 2003-05-13 09:46:08 UTC
Please upgrade to Red Hat Linux 9 official release, and see if this problem
still persists, and provide an updated status.

If the problem still persists, you may wish to also file a bug report at
http://bugs.xfree86.org in order to maximize the largest community of developers
aware of the problem whom may potentially be able to fix it.

TIA

Comment 14 Bernhard Erdmann 2003-05-15 21:31:01 UTC
sorry, this box has been given to someone else

Comment 15 Mike A. Harris 2004-01-10 16:39:53 UTC
I don't have access to ET4000 video hardware, and it is very old
legacy hardware at that, so low priority.  I'm closing this bug
as WONTFIX, however if someone with an ET4000 experiences this issue
in Fedora Core 1, they can file a bug upstream to XFree86.org at
http://bugs.xfree86.org and paste the URL here, and I will will
track the bug upstream.


Note You need to log in before you can comment on or make changes to this bug.