This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 80647 - installer issues with Trident CyberBlade chipset?
installer issues with Trident CyberBlade chipset?
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: MoveUpstream
Depends On:
Blocks: 82780
  Show dependency treegraph
 
Reported: 2002-12-29 09:17 EST by Chris Ricker
Modified: 2007-04-18 12:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-17 17:34:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
XFree86 Config file (1.91 KB, text/plain)
2003-01-28 00:59 EST, Chris Ricker
no flags Details
XFree86 log (32.21 KB, text/plain)
2003-01-28 01:02 EST, Chris Ricker
no flags Details

  None (edit)
Description Chris Ricker 2002-12-29 09:17:08 EST
I have a laptop which uses the trident cyberblade chipset, and which only works
at 1024x768.

In the past few releases of RHL, I've only been able to install by either using:

* text mode
* forcing the resolution to 1024x768

With beta3, I started an NFS install and forgot to force the resolution. When
anaconda started X, the screen went black (since anaconda tries to run at
800x600?), just as with older releases....  However, with beta3 if I switch to a
text VC, and then back to X, then anaconda displays

This seems to suggest that anaconda should Just Work on this machine in
graphical mode w/o having to force resolutions?
Comment 1 Michael Fulbright 2003-01-02 18:00:19 EST
Most likely an X server issue.
Comment 2 Chris Ricker 2003-01-24 01:21:57 EST
Saw the same thing with beta4

started install
X started
screen went black
switched to VC 1
switched back to VC 7
screen then magically worked
Comment 3 Mike A. Harris 2003-01-26 05:04:45 EST
Attach X server log, config as per usual.

TIA
Comment 4 Chris Ricker 2003-01-26 10:16:08 EST
You want it from during install, or from the working system after install?
Comment 5 Mike A. Harris 2003-01-26 17:36:17 EST
After install..   The installer tries to use the same thing that will be
used on the installed system, but if it fails, it falls back if possible
to an alternate driver.

Failures in these cases generally indicate our default driver might
not be the best one.  Also testing on an installed system is much simpler
to reproduce.  Problems that occur _only_ in the installer and not at
runtime are very difficult to debug, and very time consuming.

Trident support is sort of tapering off upstream as maintainers do less
volunteer work on older drivers and start to focus on contractual driver
work.  ;o/

We'll see what we can do though.

TIA
Comment 6 Chris Ricker 2003-01-28 00:59:27 EST
Created attachment 89635 [details]
XFree86 Config file
Comment 7 Chris Ricker 2003-01-28 01:02:07 EST
Created attachment 89636 [details]
XFree86 log
Comment 8 Chris Ricker 2003-01-28 01:04:45 EST
Attached log and config from beta4 on that machine

That machine has an LCD which only works at 1024x768 (if you run it at, say,
800x600, it displays as an 800x600 window with a 1024x768 border around it)
Comment 9 Chris Ricker 2003-02-10 10:27:07 EST
Same deal with pre-beta5
Comment 10 Mike A. Harris 2003-02-10 13:36:58 EST
The trident driver doesn't seem to be too actively maintained upstream
nowadays for all chips that it supports.  Unfortunately, without an
upstream fix, this probably wont change for our final release as I
don't have any Trident video hardware nor technical specifications
and Trident wont supply either.
Comment 11 Mike A. Harris 2003-02-14 02:37:49 EST
Would it be prefered to have the 'vesa' driver be the default for this
chip instead?  That way multiple resolutions might work perhaps.  Please
test it, and let me know if that is considered a superior default.
Comment 12 Chris Ricker 2003-02-14 11:07:38 EST
The chip actually supports multiple resolutions -- it's the LCD which is
resolution-locked. Right?
If I configure it at, say, 800x600, what I see is (warning: bad ASCII art ;-)

 ------------------------------------------------
|                                                              |
|            ------------------------------          |
|           |                                      |         |
|           |                                      |         |
|           |                                      |         |
|            ------------------------------          |
|                                                              |
-------------------------------------------------

where the inner box is an 800x600 image (my X desktop) the outer box is
1024x768, and
the border between the two is solid black

At any rate, I'll try VESA and see....
Comment 13 Mike A. Harris 2003-02-14 12:20:42 EST
You do realize that an LCD display has physically fixed size pixels on the
screen that are not changeable in size right?  Every LCD display has a
native video resolution, and only runs truely in that one resolution.

Any other resolution gets either centered on the display, or gets hardware
scaled to fit the true resolution of the display.  So no matter what, you
are using the native resolution of the display at all times.

Wether or not the Trident video hardware you have can do hardware scaling,
I have no idea, as I don't have Trident's hardware documentation.

Basically there is one of 3 possible scenarios for this problem report:

1) Your hardware doesn't support scaling (unlikely IMHO)
   - In this case, there is nothing you or anyone can do

2) Your hardware supports scaling, but the video driver does not
   - This would be an unimplemented feature and not a bug.  Someone with
     the video hardware, and the specifications for the hardware would
     have to write support for this.  I don't have the docs or hardware,
     so it wouldn't be me.  ;o)   Probably Alan Hourihane, the driver
     maintainer.

3) Your hardware supports scaling, and the driver does too, but it is broken
   for some reason on your chipset currently:
   - This would require someone who has the hardware to debug the issue,
     with the hardware right in front of them, and most likely they would
     need the Trident hardware datasheets in order to look up registers and
     programming information.  I don't have the docs or hardware,
     so it wouldn't be me.  ;o)   Probably Alan Hourihane, the driver
     maintainer.

If the vesa driver does work, and you consider it a better solution, I
will change:

(II) PCI: 01:00:0: chip 1023,8420 card 0e11,b15a rev 5d class 03,00,00 hdr 00

to use the 'vesa' driver.  Other than that, unfortunately there is not much
I can do other than hope Alan fixes it, or implements the missing feature.
Comment 14 Chris Ricker 2003-02-19 23:01:56 EST
the vesa driver doesn't seem any better

it still does the 800x600 screen centered in the middle of a fixed 1024x768
display, and
it has weird graphical artifacts all over the place

for now the best solution seems to be flipping to VC 1 and then back to X in
anaconda to
defreak X with the trident driver
Comment 15 Chris Ricker 2003-10-17 17:34:06 EDT
closing, since I no longer have the hardware

Note You need to log in before you can comment on or make changes to this bug.