Bug 806476 - Scientific Linux client/kernel upgrade failure
Scientific Linux client/kernel upgrade failure
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
1.5
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Milan Zazrivec
Red Hat Satellite QA List
:
Depends On:
Blocks: space18
  Show dependency treegraph
 
Reported: 2012-03-23 17:39 EDT by Justin Edmands
Modified: 2012-11-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-19 04:34:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Edmands 2012-03-23 17:39:07 EDT
Description of problem:
I have to delete the client from Spacewalk and re-run rhnreg_ks before upgrading from 6.0 to 6.1 and 6.1 to 6.2

Version-Release number of selected component (if applicable):
1.5

How reproducible:
Every time

Steps to Reproduce:
1.Have system fully patched on 6.1 with kernel patch bringing it to 6.2 (must happen before going to step 2)
2.Change client channel to 6.2 in Spacewalk WebUI
3.Refresh Client window
4.New Packages are available
5.WebUI: Apply updates -or- client console: yum update
  
Actual results: Tells me that no 6.2 channel available. rhn_check fails with same result


Expected results: packages to install and yum to see repo properly and install packages


Additional info:I am fairly new to Spacewalk. I had a fellow Spacewalk guy see this and he didn't know what caused this problem. I tried the rolling 6 repo and it wouldn't work.
Comment 1 Milan Zazrivec 2012-03-30 09:09:10 EDT
Could you please paste the exact output of

    rhn_check -vvv

and

    yum update

running on the client system that shows the error?

Thank you.
Comment 2 Justin Edmands 2012-04-18 12:01:09 EDT
I was unable to replicate the issue again. It appears to just be a wonky configuration on my end. I will report back if a different system produces the same problem.

Also, I just upgraded to 1.7 and added scientific linux rolling repo and it works now.
Comment 3 Milan Zazrivec 2012-04-19 04:34:23 EDT
OK, thank you for the information provided.

I'm closing this report for now as the issue you were experiencing does
now show anymore.

Note You need to log in before you can comment on or make changes to this bug.