Bug 806508 - "Unsigned packages" popup constantly reappears
"Unsigned packages" popup constantly reappears
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: apper (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-24 06:01 EDT by Mary Ellen Foster
Modified: 2012-05-03 18:50 EDT (History)
6 users (show)

See Also:
Fixed In Version: apper-0.7.1-3.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-02 00:41:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (567 bytes, patch)
2012-04-13 05:17 EDT, Mary Ellen Foster
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 289398 None None None Never

  None (edit)
Description Mary Ellen Foster 2012-03-24 06:01:11 EDT
Description of problem:
I have chromium installed from http://repos.fedorapeople.org/repos/spot/chromium/. Note that packages in this repo aren't signed.

There's currently an update to chromium. If I try to do the update through apper, it pops up the "Installing unsigned packages" warning dialogue box. If I hit "Yes", it goes away and then immediately pops back up -- indefinitely, as far as I can tell.

Doing the same update through yum works fine, and doing the apper update with chromium un-checked also works.

Version-Release number of selected component (if applicable):
apper-0.7.1-1.fc16.x86_64

How reproducible:
Every time

Steps to Reproduce:
(see above)
Comment 1 Alexey Torkhov 2012-03-28 15:25:53 EDT
Confirming. I have the same problem.
Comment 2 Mary Ellen Foster 2012-04-13 05:05:57 EDT
Still happening (I now have updates to unsigned texlive packages from http://jnovy.fedorapeople.org/texlive/)
Comment 3 Mary Ellen Foster 2012-04-13 05:17:11 EDT
Created attachment 577278 [details]
Proposed patch

... and here's what seems to be the obvious patch to fix things. Untested as yet, but I'll try it out shortly.
Comment 4 Mary Ellen Foster 2012-04-13 05:19:47 EDT
Aha, it's actually been fixed in upstream git for about 10 days, with what looks like the same patch plus a bit more bookkeeping
Comment 5 Fedora Update System 2012-04-16 17:31:24 EDT
apper-0.7.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/apper-0.7.1-2.fc17
Comment 6 Fedora Update System 2012-04-16 17:32:24 EDT
apper-0.7.1-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/apper-0.7.1-2.fc16
Comment 7 Fedora Update System 2012-04-18 15:31:54 EDT
Package apper-0.7.1-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing apper-0.7.1-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6029/apper-0.7.1-2.fc16
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-04-26 08:32:45 EDT
PackageKit-0.7.4-1.fc17, apper-0.7.1-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-6580/apper-0.7.1-4.fc17,PackageKit-0.7.4-1.fc17
Comment 9 Fedora Update System 2012-05-02 00:41:05 EDT
PackageKit-0.7.4-1.fc17, apper-0.7.1-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2012-05-03 18:50:32 EDT
apper-0.7.1-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.