Bug 806555 - isOvirt functions should check for ovirt-node-*-release
isOvirt functions should check for ovirt-node-*-release
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan Kenigsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-24 15:17 EDT by Mike Burns
Modified: 2012-08-09 03:58 EDT (History)
8 users (show)

See Also:
Fixed In Version: vdsm-4.10.0-4.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 03:58:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Burns 2012-03-24 15:17:58 EDT
Description of problem:
ovirt-node images can contain different release files depending on how they were built.  Currently those files are "ovirt-node-image-release and ovirt-node-iso-release"  

vdsm currently depends on this file being ovirt-node-image-release causing engine registration to fail if it happens to be ovirt-node-iso-release.

Version-Release number of selected component (if applicable):
4.9.3.3

How reproducible:
Always

Steps to Reproduce:
1. take latest jenkins ovirt-node-iso build
2. install and try to register
3.
  
Actual results:
vdsm-reg fails to rename the bridge to ovirtmgmt because it fails to detect that it is on an ovirt-node based image

Expected results:
registration should pass

Additional info:
Comment 1 Mike Burns 2012-03-24 15:20:28 EDT
Possible patch:

http://gerrit.ovirt.org/3055
Comment 2 Itamar Heim 2012-08-09 03:58:47 EDT
closing ON_QA bugs as oVirt 3.1 was released:
http://www.ovirt.org/get-ovirt/

Note You need to log in before you can comment on or make changes to this bug.