Bug 806585 - Fails to load plugins written in python
Summary: Fails to load plugins written in python
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: collectd
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-25 02:43 UTC by George Notaras
Modified: 2012-04-19 17:35 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-04-19 17:35:09 UTC


Attachments (Terms of Use)

Description George Notaras 2012-03-25 02:43:38 UTC
Description of problem:
Whenever a python plugin is used, there is the following error in syslog:

Unhandled python exception in importing module: ImportError: /usr/lib/python2.6/lib-dynload/_socketmodule.so: undefined symbol: PyExc_ValueError

Version-Release number of selected component (if applicable):
collectd-4.10.3-1.el6.i686

How reproducible:
Try to use any python plugin for collectd.

Workaround:
In the following page on Github there are documented two alternative methods to temporarily resolve the issue:

  https://github.com/dcarley/collectd-carbon/commit/be2c35d44664af882b54318dab557d028ca73136

I tried the first one on a 32bit system (CentOS 6.2) and I confirm that python plugins load successfully after launching collectd with ``LD_PRELOAD=/usr/lib/libpython2.6.so``. I have edited the collectd initscript as shown below:

start () {
    echo -n $"Starting $prog: "
    if [ -r "$CONFIG" ]
    then
        LD_PRELOAD=/usr/lib/libpython2.6.so daemon /usr/sbin/collectd -C "$CONFIG"
        RETVAL=$?
        echo
        [ $RETVAL -eq 0 ] && touch /var/lock/subsys/$prog
    fi
}

The second alternative workaround involves recompiling collectd, which I was too lazy to test.

Please update to a newer version or fix the issue by implementing either workaround.

Thanks

Comment 1 Fedora Update System 2012-03-25 19:10:15 UTC
collectd-4.10.6-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/collectd-4.10.6-2.el6

Comment 2 George Notaras 2012-03-25 20:47:45 UTC
Tried collectd 4.10.6 from koji (http://koji.fedoraproject.org/koji/buildinfo?buildID=309499)

Python plugins load without the aforementioned issue. Bug fixed.

Thanks

Comment 3 Fedora Update System 2012-03-25 22:27:09 UTC
Package collectd-4.10.6-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing collectd-4.10.6-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-0886/collectd-4.10.6-2.el6
then log in and leave karma (feedback).

Comment 4 Florian La Roche 2012-04-03 08:09:34 UTC
I have 4.10.7 running, which is compiled based on 4.10.6-2.epel6 and just
the upstream sources exchanged. Hope 4.10.7 will also make it into epel6.

best regards,

Florian La Roche

Comment 5 Fedora Update System 2012-04-04 19:48:37 UTC
collectd-4.10.7-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/collectd-4.10.7-1.el6

Comment 6 Fedora Update System 2012-04-19 17:35:09 UTC
collectd-4.10.7-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.