Bug 806591 - [ta_IN] SHI SHII glyphs in Lohit Tamil font need to be corrected
[ta_IN] SHI SHII glyphs in Lohit Tamil font need to be corrected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lohit-tamil-fonts (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-25 02:09 EDT by Shriramana Sharma
Modified: 2012-08-09 19:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 08:03:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Contains JPEG of attestation from printed book, PDF of current and desired appearance and TTF of replacement glyphs (35.46 KB, application/zip)
2012-03-25 02:09 EDT, Shriramana Sharma
no flags Details

  None (edit)
Description Shriramana Sharma 2012-03-25 02:09:54 EDT
Created attachment 572489 [details]
Contains JPEG of attestation from printed book, PDF of current and desired appearance and TTF of replacement glyphs

Description of problem:

The SHI SHII glyphs in Lohit Tamil font need to be corrected. In both cases the vowel sign is not correctly positioned over the consonant. Further in SHI the vowel sign does not attach to the consonant at all. 

Version-Release number of selected component (if applicable):

2.5.0

How reproducible:

Use Lohit Tamil font.

Steps to Reproduce:
1. Type ஶி ஶீ by selecting Lohit Tamil font.
2. Zoom to large size. 
3. Especially note the minute gap between SHA and VS-II.

Actual results:

You can see that the described problem exists.

Expected results:

The vowel sign should be correctly positioned w.r.t. the consonant and it should correctly attach to the consonant.

Additional info:

Currently within the SHI SHII glyph of the Lohit Tamil font the contours for the vowel sign are separate and not unified with the consonant's contours. This causes overlapping nodes which is not recommended.

Furthermore the RSB of SHI is zero, which is inappropriate. Compare the RSB values of glyphs of other consonants + VS-I.

I have modified the glyphs by taking the position of the vowel signs and the RSB values of PI/PII (PA + VS-I and VS-II) as a model since the right-side contour shape of PA is closest to that of SHA. I have provided glyphs with unified and non-unified contours. Please find it in the attachment.

I recommend to use the unified contours and have only given the non-unified contours in case you wish to do any other adjustment of positioning (unlikely).

I have also provided attestation for the actual appearance of SHI/SHII as seen in printed books,
Comment 1 Pravin Satpute 2012-05-11 03:47:14 EDT
updated this, please check http://pravins.fedorapeople.org/Lohit-Tamil.ttf and give me your comments.
Comment 2 Shriramana Sharma 2012-05-15 01:58:37 EDT
I have checked this font and the Classical equivalent and the actual reported problems for SHI and SHII are now fixed. 

I notice that you have slightly modified the contours of the leftmost section of the glyphs and especially there is one extra warning point in the SHII glyph which was not there in my replacement glyph or the previous version, but those are non-issues IMO.

So I guess it's OK to close this bug, but I think you do that only when you actually release the fixed version so I'm not doing it myself.

Thanks!
Comment 3 Pravin Satpute 2012-05-15 02:29:58 EDT
thanks for confirmation, yes i will close with new release.
Comment 4 Fedora Update System 2012-06-06 08:15:53 EDT
lohit-tamil-fonts-2.5.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/lohit-tamil-fonts-2.5.1-1.fc17
Comment 5 Fedora Update System 2012-06-06 08:33:50 EDT
lohit-tamil-fonts-2.5.1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/lohit-tamil-fonts-2.5.1-1.fc16
Comment 6 Pravin Satpute 2012-06-14 08:03:10 EDT
closing, reopen if any problem
Comment 7 Fedora Update System 2012-06-19 05:55:33 EDT
lohit-tamil-fonts-2.5.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/lohit-tamil-fonts-2.5.1-2.fc17
Comment 8 Fedora Update System 2012-07-17 13:29:23 EDT
lohit-tamil-fonts-2.5.1-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2012-08-09 19:21:57 EDT
lohit-tamil-fonts-2.5.1-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.