Bug 806605 - Running flash have inexpected results
Running flash have inexpected results
Status: CLOSED DUPLICATE of bug 804435
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
17
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-25 06:24 EDT by Marian
Modified: 2012-04-03 03:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-03 03:55:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
prevent totem-mozplugin to open an flash . (53 bytes, application/octet-stream)
2012-04-01 17:56 EDT, Marian
no flags Details

  None (edit)
Description Marian 2012-03-25 06:24:48 EDT
Description of problem:


Version-Release number of selected component (if applicable):
Firefox 11

How reproducible:


Steps to Reproduce:
1.running firefox on terminal
2.On Tools->Add-ons Manager->Plugins->Shockwave Flash (enable and disable)
3.Running flash media from different web sites.
  
Actual results:
On Shockwave Flash enabled sometimes flash is running especial from youtoube others not work.(Exception have flash material from operator cache wich have border like flash player from adobe).
On Shockwave Flash disabled all flesh running w/o exceptions.

Expected results:
On Shockwave Flash disabled all flash to fail running.

Additional info:
Comment 1 Marian 2012-03-25 12:29:35 EDT
Source of flash on cache ISP like this http://www.robtex.com/dns/*.romtele-bbu2.o-o.v20.lscache1.c.youtube.com.html#records
Comment 2 Jan Horak 2012-03-27 04:13:38 EDT
I'm a little confused here. Do you have problems with flash on specific page?

Please see https://fedoraproject.org/wiki/Debugging_guidelines_for_Mozilla_products#Reporting_addons_and_plugins_issues for instruction how to report bugs on plugins. 

The about:plugins page attached and output of:
rpm -q firefox xulrunner flash-plugin gnash google-talkplugin nspluginwrapper
ls /usr/lib64/mozilla/plugins/
ls /usr/lib/mozilla/plugins/

should be sufficient.
Comment 3 Marian 2012-03-27 08:34:22 EDT
*** nsHTMLElement::FinishDecoderSetup() mDecoder=0x7fb4060cb300 stream=0x7fb40c2e1000 src=http://o-o.preferred.romtele-bbu2.v14.lscache6.c.youtube.com/videoplayback?sparams=cp%2Cid%2Cip%2Cipbits%2Citag%2Cratebypass%2Csource%2Cexpire&fexp=907605%2C914065%2C911613%2C910207&itag=43&ip=92.0.0.0&signature=736E77739C3C4ABD1E4ABD4478DD693055C54AFF.BF7E255DE81C22525897079A44368B7DFAC4BEAA&sver=3&ratebypass=yes&source=youtube&expire=1332873325&key=yt1&ipbits=8&cp=U0hSR1hSUV9HT0NOMl9QTFVEOi1YSUF4OGpqV0wz&id=4ff5745ae34a5894

This appear on terminal-flash(non free application)is open but Shockwave Flash 11.1 r102 is disabled(a this moment flash non free running instead of not).
Other video from youtoube wich not have info on terminal is launch with Gnash 0.8.10 enabled if gnash is disabled result "This video is currently unavailable"
Comment 4 Marian 2012-03-27 08:36:46 EDT
rpm -q firefox xulrunner flash-plugin gnash google-talkplugin nspluginwrapper
firefox-11.0-2.fc17.x86_64
xulrunner-11.0-3.fc17.x86_64
flash-plugin-11.1.102.63-release.x86_64
gnash-0.8.10-2.fc17.x86_64
package google-talkplugin is not installed
package nspluginwrapper is not installed
Comment 5 Marian 2012-03-27 08:54:31 EDT
 ls /usr/lib64/mozilla/plugins/
libflashplayer.so  libgnome-shell-browser-plugin.so       libtotem-cone-plugin.so  libtotem-mully-plugin.so        libtotem-vegas-plugin.so
libgnashplugin.so  librhythmbox-itms-detection-plugin.so  libtotem-gmp-plugin.so   libtotem-narrowspace-plugin.so
ls /usr/lib/mozilla/plugins/
yum install nspluginwraper google-talkplugin 
Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit
Setting up Install Process
No package nspluginwraper available.
No package google-talkplugin available.
Comment 6 Jan Horak 2012-03-27 09:00:40 EDT
You have gnash installed, try disable it on Firefox's addon page or remove it by:
yum remove gnash
When adobe's flash plugin is disabled, gnash is supposed to run flash. It should work fine for youtube, but while it is an opensource implementation of flash you can have difficulties with other content.

Do I understand correctly that you want to disable flash completely by disabling Shockwave flash plugin on addon page?
Comment 7 Marian 2012-03-27 15:43:57 EDT
Solved this issue:yum remove totem-mozplugin.x86_64 and this it.
Comment 8 Jan Horak 2012-03-28 11:28:56 EDT
Lets change component to totem.
Comment 9 Marian 2012-04-01 17:56:09 EDT
Created attachment 574375 [details]
prevent totem-mozplugin to open an flash .
Comment 10 Marian 2012-04-01 17:57:59 EDT
mkdir /etc/totem and place file fron attachment 574375 [details].
Comment 11 Marian 2012-04-01 18:19:13 EDT
mkdir /etc/totem and place file fron attachment 574375 [details].
Comment 12 Hans de Goede 2012-04-03 03:55:32 EDT
This seems to be a dup of bug 804435, marking as such.

*** This bug has been marked as a duplicate of bug 804435 ***

Note You need to log in before you can comment on or make changes to this bug.